summaryrefslogtreecommitdiff
path: root/build/special.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build/special.mk')
-rw-r--r--build/special.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/build/special.mk b/build/special.mk
new file mode 100644
index 0000000..38e7a86
--- /dev/null
+++ b/build/special.mk
@@ -0,0 +1,36 @@
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed with
+# this work for additional information regarding copyright ownership.
+# The ASF licenses this file to You under the Apache License, Version 2.0
+# (the "License"); you may not use this file except in compliance with
+# the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+#
+# The build environment was provided by Sascha Schumann.
+
+all: all-recursive
+
+include $(builddir)/modules.mk
+
+TARGETS = $(static)
+SHARED_TARGETS = $(shared)
+INSTALL_TARGETS = install-modules-$(INSTALL_DSO)
+
+include $(top_builddir)/build/rules.mk
+
+install-modules-yes: $(SHARED_TARGETS)
+ @$(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
+ @list='$(shared)'; for i in $$list; do \
+ $(top_srcdir)/build/instdso.sh SH_LIBTOOL='$(SH_LIBTOOL)' $$i $(DESTDIR)$(libexecdir); \
+ done
+
+install-modules-no:
+