summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..bfb11d4
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,16 @@
+SUBDIRS = base graphics imaging lmfit oscpack audio video player \
+ anim wrapper python test utils samples
+
+EXTRA_DIST = avgrc avgconfigwrapper.h api.h avgconfig_win.h version.h \
+ $(wildcard glm/*.hpp) $(wildcard glm/core/*.hpp) $(wildcard glm/core/*.inl) \
+ $(wildcard glm/gtc/*.hpp) $(wildcard glm/gtc/*.inl) \
+ $(wildcard glm/gtx/*.hpp) $(wildcard glm/gtx/*.inl) \
+ $(wildcard glm/virtrev/*.hpp)
+
+BUILT_SOURCES = version.h
+DISTCLEANFILES = version.h
+
+version.h: FORCE
+ $(top_srcdir)/CreateVersionFile.py $(top_builddir)/src
+
+FORCE: