summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-07-11 15:47:59 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-09-22 15:13:36 +0200
commit5d006c27feb7c8c08df806853726c96c5d1d410c (patch)
treed9ed80c88baf7d2e25d5dbe34aede2cff2166b09
parent39797ade840fcc4f2b4b7e999d1bfb4522585218 (diff)
Fixes the install command for the python part
Gbp-Pq: Name 01_fix_python_install.patch
-rw-r--r--python/pcaptools/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/pcaptools/CMakeLists.txt b/python/pcaptools/CMakeLists.txt
index 78cfec9..3758d69 100644
--- a/python/pcaptools/CMakeLists.txt
+++ b/python/pcaptools/CMakeLists.txt
@@ -31,7 +31,7 @@ add_custom_command(OUTPUT ${OUTPUT}/timestamp
DEPENDS ${DEPS})
add_custom_target(pcapdump ALL DEPENDS ${OUTPUT}/timestamp)
-install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${SETUP_PY} build -b ${OUTPUT} install --prefix=${BUILD_ROOT}/${CMAKE_INSTALL_PREFIX})")
+install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${SETUP_PY} install --root=${CMAKE_SOURCE_DIR}/debian/tmp --install-layout=deb)")
add_custom_target(btaptap ALL DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/btaptap)
install(PROGRAMS btaptap DESTINATION ${INSTALL_DEFAULT_BINDIR})