summaryrefslogtreecommitdiff
path: root/ccrtp-config.h
diff options
context:
space:
mode:
authorJulien Cristau <jcristau@debian.org>2015-08-16 16:38:39 +0100
committerJulien Cristau <jcristau@debian.org>2015-08-16 16:38:39 +0100
commit4dca2e22af5520daee3610c8b88489910d34d2ec (patch)
tree5770c4b3e0f7d77e0079cddec0ba69094f357821 /ccrtp-config.h
libccrtp (2.0.9-2.1) unstable; urgency=medium
* Non-maintainer upload. * Rename library packages for g++5 ABI transition (closes: 791101). # imported from the archive
Diffstat (limited to 'ccrtp-config.h')
-rw-r--r--ccrtp-config.h108
1 files changed, 108 insertions, 0 deletions
diff --git a/ccrtp-config.h b/ccrtp-config.h
new file mode 100644
index 0000000..810ebfa
--- /dev/null
+++ b/ccrtp-config.h
@@ -0,0 +1,108 @@
+/* ccrtp-config.h. Generated from ccrtp-config.h.in by configure. */
+/* ccrtp-config.h.in. Generated from configure.ac by autoheader. */
+
+/* Define to 1 if you have the <dlfcn.h> header file. */
+#define HAVE_DLFCN_H 1
+
+/* Define to 1 if you have the <DL.h> header file. */
+/* #undef HAVE_DL_H */
+
+/* Define to 1 if you have the <gcrypt.h> header file. */
+#define HAVE_GCRYPT_H 1
+
+/* Define to 1 if you have the <inttypes.h> header file. */
+#define HAVE_INTTYPES_H 1
+
+/* Define to 1 if you have the `nana' library (-lnana). */
+/* #undef HAVE_LIBNANA */
+
+/* Define to 1 if you have the <memory.h> header file. */
+#define HAVE_MEMORY_H 1
+
+/* Define to 1 if you have the <openssl/aes.h> header file. */
+/* #undef HAVE_OPENSSL_AES_H */
+
+/* Define to 1 if you have the <openssl/bn.h> header file. */
+/* #undef HAVE_OPENSSL_BN_H */
+
+/* Define to 1 if you have the <openssl/sha.h> header file. */
+/* #undef HAVE_OPENSSL_SHA_H */
+
+/* Define to 1 if you have the <stdint.h> header file. */
+#define HAVE_STDINT_H 1
+
+/* Define to 1 if you have the <stdlib.h> header file. */
+#define HAVE_STDLIB_H 1
+
+/* Define to 1 if you have the <strings.h> header file. */
+#define HAVE_STRINGS_H 1
+
+/* Define to 1 if you have the <string.h> header file. */
+#define HAVE_STRING_H 1
+
+/* Define to 1 if you have the <sys/stat.h> header file. */
+#define HAVE_SYS_STAT_H 1
+
+/* Define to 1 if you have the <sys/types.h> header file. */
+#define HAVE_SYS_TYPES_H 1
+
+/* Define to 1 if you have the <unistd.h> header file. */
+#define HAVE_UNISTD_H 1
+
+/* Define to the sub-directory in which libtool stores uninstalled libraries.
+ */
+#define LT_OBJDIR ".libs/"
+
+/* Name of package */
+#define PACKAGE "ccrtp"
+
+/* Define to the address where bug reports for this package should be sent. */
+#define PACKAGE_BUGREPORT ""
+
+/* Define to the full name of this package. */
+#define PACKAGE_NAME "ccrtp"
+
+/* Define to the full name and version of this package. */
+#define PACKAGE_STRING "ccrtp 2.0.9"
+
+/* Define to the one symbol short name of this package. */
+#define PACKAGE_TARNAME "ccrtp"
+
+/* Define to the home page for this package. */
+#define PACKAGE_URL ""
+
+/* Define to the version of this package. */
+#define PACKAGE_VERSION "2.0.9"
+
+/* SRTP support */
+#define SRTP_SUPPORT /**/
+
+/* Define to 1 if you have the ANSI C header files. */
+#define STDC_HEADERS 1
+
+/* Version number of package */
+#define VERSION "2.0.9"
+
+/* Define to `__inline__' or `__inline' if that's what the C compiler
+ calls it, or to nothing if 'inline' is not supported under any name. */
+#ifndef __cplusplus
+/* #undef inline */
+#endif
+
+/* Define to the equivalent of the C99 'restrict' keyword, or to
+ nothing if this is not supported. Do not define if restrict is
+ supported directly. */
+#define restrict __restrict
+/* Work around a bug in Sun C++: it does not support _Restrict or
+ __restrict__, even though the corresponding Sun C compiler ends up with
+ "#define restrict _Restrict" or "#define restrict __restrict__" in the
+ previous line. Perhaps some future version of Sun C++ will work with
+ restrict; if so, hopefully it defines __RESTRICT like Sun C does. */
+#if defined __SUNPRO_CC && !defined __RESTRICT
+# define _Restrict
+# define __restrict__
+#endif
+
+/* Define to empty if the keyword `volatile' does not work. Warning: valid
+ code using `volatile' can become incorrect without. Disable with care. */
+/* #undef volatile */