summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/additions/examples/c++/debian.Makefile5
-rw-r--r--debian/additions/examples/c/debian.Makefile5
-rw-r--r--debian/changelog163
-rw-r--r--debian/compat2
-rw-r--r--debian/control126
-rw-r--r--debian/copyright37
-rw-r--r--debian/dirs1
-rw-r--r--debian/libconfig++-dev.examples4
-rw-r--r--debian/libconfig++-dev.install4
-rw-r--r--debian/libconfig++9-dev.install5
-rw-r--r--debian/libconfig++9.install1
-rw-r--r--debian/libconfig++9v5.install1
-rw-r--r--debian/libconfig-dev.examples3
-rw-r--r--debian/libconfig-dev.info (renamed from debian/libconfig9.info)0
-rw-r--r--debian/libconfig-dev.install4
-rw-r--r--debian/libconfig-doc.doc-base9
-rw-r--r--debian/libconfig-doc.docs1
-rw-r--r--debian/libconfig9.install3
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/tex-workaround.patch18
-rwxr-xr-xdebian/rules109
-rw-r--r--debian/source/format1
22 files changed, 294 insertions, 209 deletions
diff --git a/debian/additions/examples/c++/debian.Makefile b/debian/additions/examples/c++/debian.Makefile
new file mode 100644
index 0000000..bcd48bb
--- /dev/null
+++ b/debian/additions/examples/c++/debian.Makefile
@@ -0,0 +1,5 @@
+all: example1 example2 example3 example4
+
+LOADLIBES += $(shell pkg-config libconfig++ --libs)
+CXXFLAGS += -Wall
+CXXFLAGS += -O2
diff --git a/debian/additions/examples/c/debian.Makefile b/debian/additions/examples/c/debian.Makefile
new file mode 100644
index 0000000..a5e28bd
--- /dev/null
+++ b/debian/additions/examples/c/debian.Makefile
@@ -0,0 +1,5 @@
+all: example1 example2 example3
+
+LOADLIBES += $(shell pkg-config libconfig --libs)
+CFLAGS += -Wall
+CFLAGS += -O2
diff --git a/debian/changelog b/debian/changelog
index 7e9e00a..8cfa8fe 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,26 +1,138 @@
-libconfig (1.4.8) unstable; urgency=low
+libconfig (1.5-0.3) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Fix FTBFS when built with dpkg-buildpackage -A.
+ Thanks to Santiago Vila <sanvila@unex.es> (Closes: #806627)
+ * Remove Jose Luis Tallon from Uploaders list. (Closes: #838077)
+
+ -- Dr. Tobias Quathamer <toddy@debian.org> Sat, 26 Nov 2016 23:19:25 +0100
+
+libconfig (1.5-0.2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Upload to unstable.
+
+ -- Matthias Klose <doko@debian.org> Tue, 04 Aug 2015 17:20:08 +0200
+
+libconfig (1.5-0.1) experimental; urgency=medium
+
+ * Non maintainer upload.
+ * New upstream version.
+ * Rename libconfig++9v5 to libconfig++9v5, libstdc++6 ABI symbol changes.
+ Addresses: #791108.
+ * Add Conflicts/Replaces to the old library.
+ * Don't ship libconfig9.info in libconfig9, but only in libconfig-dev.
+ * Drop versioned dependency on pkg-config. Closes: #734482.
+ * Enable parallel builds. Closes: #759581.
+ * Only build the libconfig documentation for binary indep builds.
+ Closes: #759582.
+ * Add build dependency on texlive-fonts-recommended.
+ * Bump standards version to 3.9.6.
+
+ -- Matthias Klose <doko@ubuntu.com> Wed, 29 Jul 2015 12:46:50 +0200
+
+libconfig (1.4.9-2) unstable; urgency=medium
+
+ * Update short package description (Closes: #710783)
+ * Build using dh-autoreconf rather than autotools-dev; thanks to Matthias
+ Klose for this fix
+ * Add tex-workaround.patch from Matthias Klose to fix texinfo/tex FTBFS
+ * With sponsor's blessing, set myself as maintainer
+ * Bump Standards-Version to 3.9.5
+ - No changes required
+
+ -- Jonathan McCrohan <jmccrohan@gmail.com> Sat, 28 Dec 2013 17:41:20 +0000
+
+libconfig (1.4.9-1) unstable; urgency=low
* New upstream release
- * Update debian/control to reflect current Debian packages
- * Add texlive-latex-base to Build-Depends
+ * Update S-V to 3.9.4
+ - No changes necessary
+ * Ensure that libconfig++-dbg depends on libconfig9 (= ${binary:Version})
+ in addition to libconfig++9 (= ${binary:Version})
+ - Fixes dbg-package-missing-depends lintian warning
+
+ -- Jonathan McCrohan <jmccrohan@gmail.com> Sat, 12 Oct 2013 16:41:14 +0100
+
+libconfig (1.4.8-5) unstable; urgency=low
+
+ * Switch to dh_9 style rules file
+ - Hardened buildflags now provided automatically
+ - Fixes E-binary-arch-produces-all buildd warning
+
+ -- Jonathan McCrohan <jmccrohan@gmail.com> Tue, 26 Jun 2012 21:41:22 +0100
+
+libconfig (1.4.8-4) unstable; urgency=low
+
+ * Add C++ hardened buildflags
+ - Thanks to Simon Ruderich for the patch (closes: #662225)
+ * Fix libconfig(++)8-dev transition packages
+ - Set section as oldlibs
+ - Set priority as extra
+ - Remove package descriptions
+ * Add Multiarch support
+
+ -- Jonathan McCrohan <jmccrohan@gmail.com> Fri, 06 Apr 2012 14:28:39 +0100
+
+libconfig (1.4.8-3) unstable; urgency=low
+
+ * Add Replaces+Breaks: libconfig(++)8-dev to libconfig(++)-dev
+ - Thanks to Andreas Beckmann for reporting (closes: #662643)
+ * Enable hardened buildflags
+ - Thanks to Simon Ruderich for the patch (closes: #662225)
+ * Fix incorrect section and arch for transitional packages.
- -- Jonathan McCrohan <jmccrohan@gmail.com> Sun, 06 Nov 2011 01:16:39 +0000
+ -- Jonathan McCrohan <jmccrohan@gmail.com> Mon, 05 Mar 2012 22:01:29 +0000
-libconfig (1.4) unstable; urgency=low
+libconfig (1.4.8-2) unstable; urgency=low
- * new upstream release
- * libconfig++9-dev no longer depends on libconfig9-dev
+ * Upload to unstable
+ * Update to S-V 3.9.3
+ * debian/rules now uses dpkg-buildflags
+ * Provide full transitional packages to help -dev package rename
+ * Multiple lintian fixes
+ - out-of-date-standards-version
+ - copyright-with-old-dh-make-debian-copyright
+ - extended-description-is-probably-too-short
+ - unneeded-build-dep-on-quilt
- -- Mark Lindner <hyperrealm@gmail.com> Fri, 21 Aug 2009 00:00:00 +0800
+ -- Jonathan McCrohan <jmccrohan@gmail.com> Thu, 01 Mar 2012 02:11:47 +0000
-libconfig (1.3.2) unstable; urgency=low
+libconfig (1.4.8-1~exp1) experimental; urgency=low
- * new upstream release
- * use official Debian files as basis
- * libconfig++8-dev depends on libconfig8-dev because libconfig.h++
- includes libconfig.h which is in libconfig8-dev
+ * New upstream release (closes: #583528)
+ - soname bump to 9
+ * Update to S-V 3.9.2
+ * Update to Debhelper v7
+ * Refresh Build-Depends packages
+ * Add debug packages
+ * Remove soname from -dev package names
+ - Build as virtual packages for reverse dependency purposes.
+ * Fix examples (closes: #632081)
- -- Klaus Schneider <kschn@users.sourceforge.net> Wed, 18 Feb 2009 15:26:32 +0100
+ -- Jonathan McCrohan <jmccrohan@gmail.com> Sat, 11 Feb 2012 18:13:26 +0000
+
+libconfig (1.3.2-2) unstable; urgency=low
+
+ * Removed "conflicts" with older sonames (Closes: #536635)
+ * Added missing compile-time libconfig++8-dev dependencies
+ (libconfig8-dev) (Closes: #537311)
+
+ * Removed libtool's ".la" files (clients should use pkg-config)
+
+ * Updated to S-V 3.8.3 with no changes
+
+ * With many thanks to Christian Hammers, who kindly checked the package.
+
+ -- Jose Luis Tallon <jltallon@adv-solutions.net> Sun, 13 Sep 2009 04:25:14 +0200
+
+libconfig (1.3.2-1) unstable; urgency=low
+
+ * New upstream release (Closes: #521725)
+ - soname bump to 8
+ - Updated to S-V 3.8.1 with no changes
+
+ -- Jose Luis Tallon <jltallon@adv-solutions.net> Tue, 07 Apr 2009 21:13:16 +0200
libconfig (1.3.1-1) unstable; urgency=low
@@ -52,26 +164,3 @@ libconfig (0.9-1) unstable; urgency=low
-- Jose Luis Tallon <jltallon@adv-solutions.net> Tue, 10 Oct 2006 01:42:09 +0200
-libconfigduo (1.3.1) unstable; urgency=low
-
- * Release 1.3.1
-
- -- Klaus Schneider <kschn@users.sourceforge.net> Thu, 13 Nov 2008 17:05:12 +0100
-
-libconfigduo (1.3) unstable; urgency=low
-
- * Release 1.3
-
- -- Klaus Schneider <kschn@users.sourceforge.net> Fri, 4 Apr 2008 09:36:42 +0200
-
-libconfigduo (1.2.1-1) unstable; urgency=low
-
- * Release 1.2.1
-
- -- Klaus Schneider <kschn@users.sourceforge.net> Thu, 31 Jan 2008 11:25:21 +0100
-
-libconfigduo (1.1.1-1) unstable; urgency=low
-
- * Initial release
-
- -- Klaus Schneider <kschn@users.sourceforge.net> Mon, 25 Jun 2007 16:21:56 +0200
diff --git a/debian/compat b/debian/compat
index 7ed6ff8..ec63514 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-5
+9
diff --git a/debian/control b/debian/control
index 5ac5e83..54fcac6 100644
--- a/debian/control
+++ b/debian/control
@@ -1,33 +1,37 @@
Source: libconfig
Priority: optional
-Maintainer: Klaus Schneider <kschn@users.sourceforge.net>
-Uploaders: Julien Danjou <acid@debian.org>
-Build-Depends: debhelper (>= 5), autotools-dev, texinfo, texlive-latex-base
-Standards-Version: 3.8.0
+Maintainer: Jonathan McCrohan <jmccrohan@gmail.com>
+Build-Depends: debhelper (>= 9), dh-autoreconf, texinfo, g++ (>= 4:5)
+Build-Depends-Indep: texlive-latex-base, texlive-fonts-recommended
+Standards-Version: 3.9.6
Homepage: http://www.hyperrealm.com/libconfig/
Section: libs
Package: libconfig9
-Section: libs
Architecture: any
+Pre-Depends: ${misc:Pre-Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: processing of structured configuration files
+Multi-Arch: same
+Description: parsing/manipulation of structured configuration files
This library features a fully reentrant parser and includes bindings for
both the C and C++ programming languages. It runs on modern POSIX-compliant
- systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
+ systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
Microsoft Windows 2000/XP and later (Visual Studio or MinGW).
.
This library allows parsing, manipulating and writing structured configuration
files.
-Package: libconfig++9
-Section: libs
+Package: libconfig++9v5
Architecture: any
+Pre-Depends: ${misc:Pre-Depends}
Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: processing of structured configuration files (C++ binding)
+Conflicts: libconfig++9
+Replaces: libconfig++9
+Multi-Arch: same
+Description: parsing/manipulation of structured configuration files (C++ binding)
This library features a fully reentrant parser and includes bindings for
both the C and C++ programming languages. It runs on modern POSIX-compliant
- systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
+ systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
Microsoft Windows 2000/XP and later (Visual Studio or MinGW).
.
This library allows parsing, manipulating and writing structured configuration
@@ -35,16 +39,18 @@ Description: processing of structured configuration files (C++ binding)
.
This is the C++ binding.
-Package: libconfig9-dev
+Package: libconfig-dev
Section: libdevel
Architecture: any
-Provides: libconfig-dev
-Depends: libconfig9 (= ${binary:Version}), pkg-config (>= 0.20)
-Conflicts: libconfig8-dev
-Description: processing of structured config files (development)
+Replaces: libconfig8-dev (<< 1.4.8)
+Breaks: libconfig8-dev (<< 1.4.8)
+Depends: libconfig9 (= ${binary:Version}), pkg-config, ${misc:Depends}
+Recommends: libconfig-doc
+Multi-Arch: same
+Description: parsing/manipulation of structured config files (development)
This library features a fully reentrant parser and includes bindings for
both the C and C++ programming languages. It runs on modern POSIX-compliant
- systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
+ systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
Microsoft Windows 2000/XP and later (Visual Studio or MinGW).
.
This library allows parsing, manipulating and writing structured configuration
@@ -59,16 +65,27 @@ Description: processing of structured config files (development)
This package contains the files needed in order to use libconfig
in your own programs.
-Package: libconfig++9-dev
+Package: libconfig8-dev
+Depends: libconfig-dev, ${misc:Depends}
+Architecture: any
+Section: oldlibs
+Priority: extra
+Description: Transitional package for libconfig-dev
+ This is a transitional package for libconfig-dev, and can be safely removed
+ when no other package depends on it.
+
+Package: libconfig++-dev
Section: libdevel
Architecture: any
-Provides: libconfig++-dev
-Depends: libconfig++9 (= ${binary:Version}), libconfig9 (= ${binary:Version}), pkg-config (>= 0.20)
-Conflicts: libconfig++8-dev
-Description: processing of structured config files (C++ development)
+Replaces: libconfig++8-dev (<< 1.4.8)
+Breaks: libconfig++8-dev (<< 1.4.8)
+Depends: libconfig++9v5 (= ${binary:Version}), libconfig-dev,
+ pkg-config, ${misc:Depends}
+Multi-Arch: same
+Description: parsing/manipulation of structured config files (C++ development)
This library features a fully reentrant parser and includes bindings for
both the C and C++ programming languages. It runs on modern POSIX-compliant
- systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
+ systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
Microsoft Windows 2000/XP and later (Visual Studio or MinGW).
.
This library allows parsing, manipulating and writing structured configuration
@@ -83,16 +100,63 @@ Description: processing of structured config files (C++ development)
This package contains the files needed in order to use libconfig
in your own C++ programs.
-Package: libconfig9-dbg
+Package: libconfig++8-dev
+Depends: libconfig++-dev, ${misc:Depends}
+Architecture: any
+Section: oldlibs
+Priority: extra
+Description: Transitional package for libconfig++-dev
+ This is a transitional package for libconfig++-dev, and can be safely removed
+ when no other package depends on it.
+
+
+Package: libconfig-dbg
Section: debug
+Priority: extra
Architecture: any
-Depends: libconfig9 (= ${binary:Version})
-Description: debug symbols for libconfig9
- This package provides debugging information for libconfig library
+Depends: libconfig9 (= ${binary:Version}), ${misc:Depends}
+Multi-Arch: same
+Description: parsing/manipulation of structured config files (debug symbols)
+ This library features a fully reentrant parser and includes bindings for
+ both the C and C++ programming languages. It runs on modern POSIX-compliant
+ systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
+ Microsoft Windows 2000/XP and later (Visual Studio or MinGW).
+ .
+ This library allows parsing, manipulating and writing structured configuration
+ files.
+ .
+ This package provides debugging information for the libconfig library.
-Package: libconfig++9-dbg
+Package: libconfig++-dbg
Section: debug
+Priority: extra
Architecture: any
-Depends: libconfig++9 (= ${binary:Version})
-Description: debug symbols for libconfig++9
- This package provides debugging information for C++ API of libconfig library
+Depends: libconfig9 (= ${binary:Version}), libconfig++9v5 (= ${binary:Version}), ${misc:Depends}
+Multi-Arch: same
+Description: parsing/manipulation of structured config files (C++ debug symbols)
+ This library features a fully reentrant parser and includes bindings for
+ both the C and C++ programming languages. It runs on modern POSIX-compliant
+ systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
+ Microsoft Windows 2000/XP and later (Visual Studio or MinGW).
+ .
+ This library allows parsing, manipulating and writing structured configuration
+ files.
+ .
+ This package provides debugging information for the libconfig++ library.
+
+Package: libconfig-doc
+Section: doc
+Architecture: all
+Replaces: libconfig-dev (<= 1.4.8)
+Breaks: libconfig-dev (<= 1.4.8)
+Depends: ${misc:Depends}
+Description: parsing/manipulation of structured config files (Documentation)
+ This library features a fully reentrant parser and includes bindings for
+ both the C and C++ programming languages. It runs on modern POSIX-compliant
+ systems such as Linux, Solaris, and Mac OS X (Darwin), as well as on
+ Microsoft Windows 2000/XP and later (Visual Studio or MinGW).
+ .
+ This library allows parsing, manipulating and writing structured configuration
+ files.
+ .
+ This package provides documentation for the libconfig library.
diff --git a/debian/copyright b/debian/copyright
index e6e57d0..c5556f6 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -30,36 +30,7 @@ On Debian systems, the full text of GNU's Lesser General Public License can
be found at /usr/share/common-licenses/LGPL-2.1
-The Debian packaging is (C) 2006-2008, Jose Luis Tallon <jltallon@adv-solutions.net>
-and is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
-This package was debianized by Klaus Schneider <kschn@users.sourceforge.net> on
-Mon, 25 Jun 2007 16:21:56 +0200.
-
-It was downloaded from http://www.hyperrealm.com/libconfig/libconfig.html
-
-Upstream Author: Mark A. Lindner
-
-Copyright: (c) 2005-2009 Mark A. Lindner
-
-License:
-
- This package is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2 of the License, or (at your option) any later version.
-
- This package is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.
-
- You should have received a copy of the GNU Lesser General Public
- License along with this package; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-
-On Debian systems, the complete text of the GNU Lesser General
-Public License can be found in `/usr/share/common-licenses/LGPL'.
-
-
-The Debian packaging is (C) 2007, Klaus Schneider <kschn@users.sourceforge.net> and
-is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
+The Debian packaging is copyright 2006-2009, Jose Luis Tallon
+<jltallon@adv-solutions.net>, copyright 2011-2012, Jonathan McCrohan
+<jmccrohan@gmail.com> and is licensed under the GPL version 2, see
+`/usr/share/common-licenses/GPL-2'.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..6845771
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1 @@
+usr/lib
diff --git a/debian/libconfig++-dev.examples b/debian/libconfig++-dev.examples
new file mode 100644
index 0000000..2d79c34
--- /dev/null
+++ b/debian/libconfig++-dev.examples
@@ -0,0 +1,4 @@
+examples/c++/example.cfg
+examples/c++/invalid.cfg
+examples/c++/example*.cpp
+debian/additions/examples/c++/debian.Makefile
diff --git a/debian/libconfig++-dev.install b/debian/libconfig++-dev.install
new file mode 100644
index 0000000..75c2d47
--- /dev/null
+++ b/debian/libconfig++-dev.install
@@ -0,0 +1,4 @@
+debian/tmp/usr/include/libconfig.h++
+debian/tmp/usr/lib/*/libconfig++.a
+debian/tmp/usr/lib/*/libconfig++.so
+debian/tmp/usr/lib/*/pkgconfig/libconfig++.pc
diff --git a/debian/libconfig++9-dev.install b/debian/libconfig++9-dev.install
deleted file mode 100644
index 642348a..0000000
--- a/debian/libconfig++9-dev.install
+++ /dev/null
@@ -1,5 +0,0 @@
-debian/tmp/usr/include/libconfig.h++
-debian/tmp/usr/lib/libconfig++.a
-debian/tmp/usr/lib/libconfig++.so
-debian/tmp/usr/lib/libconfig++.la
-debian/tmp/usr/lib/pkgconfig/libconfig++.pc
diff --git a/debian/libconfig++9.install b/debian/libconfig++9.install
deleted file mode 100644
index 35c586e..0000000
--- a/debian/libconfig++9.install
+++ /dev/null
@@ -1 +0,0 @@
-debian/tmp/usr/lib/libconfig++.so.9*
diff --git a/debian/libconfig++9v5.install b/debian/libconfig++9v5.install
new file mode 100644
index 0000000..f63c7e9
--- /dev/null
+++ b/debian/libconfig++9v5.install
@@ -0,0 +1 @@
+debian/tmp/usr/lib/*/libconfig++.so.9*
diff --git a/debian/libconfig-dev.examples b/debian/libconfig-dev.examples
new file mode 100644
index 0000000..af50e71
--- /dev/null
+++ b/debian/libconfig-dev.examples
@@ -0,0 +1,3 @@
+examples/c/example.cfg
+examples/c/example*.c
+debian/additions/examples/c/debian.Makefile
diff --git a/debian/libconfig9.info b/debian/libconfig-dev.info
index 628d7f3..628d7f3 100644
--- a/debian/libconfig9.info
+++ b/debian/libconfig-dev.info
diff --git a/debian/libconfig-dev.install b/debian/libconfig-dev.install
new file mode 100644
index 0000000..375054d
--- /dev/null
+++ b/debian/libconfig-dev.install
@@ -0,0 +1,4 @@
+debian/tmp/usr/include/libconfig.h
+debian/tmp/usr/lib/*/libconfig.a
+debian/tmp/usr/lib/*/libconfig.so
+debian/tmp/usr/lib/*/pkgconfig/libconfig.pc
diff --git a/debian/libconfig-doc.doc-base b/debian/libconfig-doc.doc-base
new file mode 100644
index 0000000..281715e
--- /dev/null
+++ b/debian/libconfig-doc.doc-base
@@ -0,0 +1,9 @@
+Document: libconfig9
+Title: libconfig manual
+Author: Mark A Lindner
+Abstract: This manual describes what libconfig is
+ and how it can be used to parse configuration files
+Section: Programming/C
+
+Format: PDF
+Files: /usr/share/doc/libconfig-doc/libconfig.pdf.gz
diff --git a/debian/libconfig-doc.docs b/debian/libconfig-doc.docs
new file mode 100644
index 0000000..49e707d
--- /dev/null
+++ b/debian/libconfig-doc.docs
@@ -0,0 +1 @@
+doc/libconfig.pdf
diff --git a/debian/libconfig9.install b/debian/libconfig9.install
index aba7b37..9064128 100644
--- a/debian/libconfig9.install
+++ b/debian/libconfig9.install
@@ -1,2 +1 @@
-debian/tmp/usr/lib/libconfig.so.9*
-
+debian/tmp/usr/lib/*/libconfig.so.9*
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..ee29cc9
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+tex-workaround.patch
diff --git a/debian/patches/tex-workaround.patch b/debian/patches/tex-workaround.patch
new file mode 100644
index 0000000..9bb4857
--- /dev/null
+++ b/debian/patches/tex-workaround.patch
@@ -0,0 +1,18 @@
+Description: Fix textinfo/tex FTBFS
+Author: Matthias Klose <doko@ubuntu.com>
+Date: Tue, 17 Dec 2013 13:54:38 +0100
+---
+--- a/doc/libconfig.texi 2012-09-29 04:20:48.000000000 +0000
++++ b/doc/libconfig.texi 2013-12-17 12:52:14.886009579 +0000
+@@ -467,9 +467,9 @@
+
+ A group has the form:
+
+-@b{@{}
++@b{lbracechar}
+ @i{settings ...}
+-@b{@}}
++@b{rbracechar}
+
+ Groups can contain any number of settings, but each setting must have
+ a unique name within the group.
diff --git a/debian/rules b/debian/rules
index d758c24..db47cba 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,105 +1,16 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+# # export DH_VERBOSE=1
+override_dh_auto_test-indep:
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+override_dh_auto_build-indep:
+ $(MAKE) -C doc pdf
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-# shared library versions
-version=`ls lib/.libs/lib*.so.* | \
- awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
-major=`ls lib/.libs/lib*.so.* | \
- awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
-
-config.status: configure
- dh_testdir
- ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=/usr --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info \
- CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
-
-build: build-stamp
-build-stamp: config.status
- dh_testdir
- $(MAKE)
- $(MAKE) pdf
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- -$(MAKE) distclean
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
-endif
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
- dh_install
- dh_strip -v --package=libconfig9 --dbg-package=libconfig9-dbg
- dh_strip -v --package=libconfig++9 --dbg-package=libconfig++9-dbg
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
-# dh_perl
-# dh_python
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_strip:
+ dh_strip -p libconfig9 --dbg-package=libconfig-dbg
+ dh_strip -p libconfig++9v5 --dbg-package=libconfig++-dbg
+
+%:
+ dh $@ --parallel --with autoreconf
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)