summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2024-03-31 00:48:07 +0100
committergregor herrmann <gregoa@debian.org>2024-03-31 00:48:07 +0100
commitd640c313a428f33225fdcd215225b967fca9831c (patch)
tree1d881879f4883a5bef8edaddaf23a1ec7439b37f
parentbf0cd6220ff5d39813b7910c253692585fb83515 (diff)
parentebcac827145b32cbeefae3951fa348e92da5f91c (diff)
Update upstream source from tag 'upstream/0.30'
Update to upstream version '0.30' with Debian dir 1001afd4c784f8fb9389c3cb4fa6095dc7139a9a
-rw-r--r--Changes4
-rw-r--r--META.json10
-rw-r--r--META.yml8
-rw-r--r--Makefile.PL1
-rw-r--r--SMIME.pl2
-rw-r--r--lib/SMIME.pm27
6 files changed, 41 insertions, 11 deletions
diff --git a/Changes b/Changes
index c64b267..5ad751d 100644
--- a/Changes
+++ b/Changes
@@ -1,5 +1,9 @@
Revision history for Crypt::SMIME
+0.30 Mon Mar 25 11:13:13 JST 2024
+ - Added missing licence info to META files:
+ https://rt.cpan.org/Public/Bug/Display.html?id=152521
+
0.29 Mon Mar 4 18:10:38 JST 2024
- Fixed a bug which could cause a double-free on X.509
structures in a certain scenario:
diff --git a/META.json b/META.json
index 1a705d9..4196c6c 100644
--- a/META.json
+++ b/META.json
@@ -4,13 +4,13 @@
"Ymirlink <tl@tripletail.jp>"
],
"dynamic_config" : 1,
- "generated_by" : "ExtUtils::MakeMaker version 7.64, CPAN::Meta::Converter version 2.150010",
+ "generated_by" : "ExtUtils::MakeMaker version 7.1, CPAN::Meta::Converter version 2.150005",
"license" : [
- "unknown"
+ "perl_5"
],
"meta-spec" : {
"url" : "http://search.cpan.org/perldoc?CPAN::Meta::Spec",
- "version" : 2
+ "version" : "2"
},
"name" : "Crypt-SMIME",
"no_index" : {
@@ -42,6 +42,6 @@
}
},
"release_status" : "stable",
- "version" : "0.29",
- "x_serialization_backend" : "JSON::PP version 4.07"
+ "version" : "0.30",
+ "x_serialization_backend" : "JSON::PP version 2.27203"
}
diff --git a/META.yml b/META.yml
index a3789df..9c2f59e 100644
--- a/META.yml
+++ b/META.yml
@@ -12,8 +12,8 @@ configure_requires:
ExtUtils::MakeMaker: '0'
ExtUtils::PkgConfig: '0'
dynamic_config: 1
-generated_by: 'ExtUtils::MakeMaker version 7.64, CPAN::Meta::Converter version 2.150010'
-license: unknown
+generated_by: 'ExtUtils::MakeMaker version 7.1, CPAN::Meta::Converter version 2.150005'
+license: perl
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.4.html
version: '1.4'
@@ -24,5 +24,5 @@ no_index:
- inc
requires:
XSLoader: '0'
-version: '0.29'
-x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
+version: '0.30'
+x_serialization_backend: 'CPAN::Meta::YAML version 0.016'
diff --git a/Makefile.PL b/Makefile.PL
index 487db15..2d86303 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -24,6 +24,7 @@ WriteMakefile(
AUTHOR => 'Ymirlink <tl@tripletail.jp>',
VERSION_FROM => 'SMIME.pl',
ABSTRACT => 'S/MIME message signing, verification, encryption and decryption',
+ LICENSE => 'perl_5',
PL_FILES => {},
CONFIGURE_REQUIRES => {
'ExtUtils::CChecker' => 0,
diff --git a/SMIME.pl b/SMIME.pl
index 28e9402..c473d08 100644
--- a/SMIME.pl
+++ b/SMIME.pl
@@ -15,7 +15,7 @@ our %EXPORT_TAGS = (
);
Exporter::export_ok_tags('constants');
-our $VERSION = '0.29';
+our $VERSION = '0.30';
XSLoader::load(__PACKAGE__, $VERSION);
diff --git a/lib/SMIME.pm b/lib/SMIME.pm
index ebfa629..563a093 100644
--- a/lib/SMIME.pm
+++ b/lib/SMIME.pm
@@ -17,7 +17,7 @@ our %EXPORT_TAGS = (
);
Exporter::export_ok_tags('constants');
-our $VERSION = '0.29';
+our $VERSION = '0.30';
XSLoader::load(__PACKAGE__, $VERSION);
@@ -184,6 +184,31 @@ sub prepareSmimeMessage {
}
($rest,$move);
}
+use Carp qw(croak);
+sub AUTOLOAD {
+ # This AUTOLOAD is used to 'autoload' constants from the constant()
+ # XS function.
+
+ my $constname;
+ our $AUTOLOAD;
+ ($constname = $AUTOLOAD) =~ s/.*:://;
+ croak "&Crypt::SMIME::constant not defined" if $constname eq 'constant';
+ my ($error, $val) = constant($constname);
+ if ($error) { croak $error; }
+ {
+ no strict 'refs';
+ # Fixed between 5.005_53 and 5.005_61
+#XXX if ($] >= 5.00561) {
+#XXX *$AUTOLOAD = sub () { $val };
+#XXX }
+#XXX else {
+ *$AUTOLOAD = sub { $val };
+#XXX }
+ }
+ goto &$AUTOLOAD;
+}
+
+
__END__
=encoding utf-8