summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Miko <karel.miko@gmail.com>2016-07-03 14:05:15 +0200
committerKarel Miko <karel.miko@gmail.com>2016-07-03 14:05:15 +0200
commit9b4c9d0adc13d31ede1253fdce1363c502a06e86 (patch)
tree9a05116432ac47a38d9548ba117d7e457bd5d71f
parentdd7c00dfcfe546156e0571184b9fecb272c548f8 (diff)
libtomcrypt (renaming *tab.c > *tab.c.inc not needed anymore)
-rw-r--r--Changes1
-rwxr-xr-xMakefile.PL2
-rw-r--r--src/ltc/ciphers/aes/aes.c2
-rw-r--r--src/ltc/ciphers/aes/aes_tab.c (renamed from src/ltc/ciphers/aes/aes_tab.c.inc)0
-rw-r--r--src/ltc/ciphers/safer/safer.c2
-rwxr-xr-xsrc/ltc/ciphers/safer/safer_tab.c (renamed from src/ltc/ciphers/safer/safer_tab.c.inc)0
-rw-r--r--src/ltc/ciphers/safer/saferp.c2
-rw-r--r--src/ltc/ciphers/twofish/twofish.c2
-rwxr-xr-xsrc/ltc/ciphers/twofish/twofish_tab.c (renamed from src/ltc/ciphers/twofish/twofish_tab.c.inc)0
-rw-r--r--src/ltc/hashes/whirl/whirl.c2
-rwxr-xr-xsrc/ltc/hashes/whirl/whirltab.c (renamed from src/ltc/hashes/whirl/whirltab.c.inc)0
-rw-r--r--src/ltc/mac/pelican/pelican.c2
-rw-r--r--src/ltc/prngs/sober128.c2
-rwxr-xr-xsrc/ltc/prngs/sober128tab.c (renamed from src/ltc/prngs/sober128tab.c.inc)0
14 files changed, 9 insertions, 8 deletions
diff --git a/Changes b/Changes
index 9eb8d6fa..5a8fc2a9 100644
--- a/Changes
+++ b/Changes
@@ -17,6 +17,7 @@ TODO:
- Math::BigInt::LTM fixed mp_invmod(a,b,c) for b == 1
- Math::BigInt::LTM fixed _log_int()
- fix 'Please specify prototyping behavior for CryptX.xs'
+ - libtomcrypt (renaming *tab.c > *tab.c.inc not needed anymore)
0.037 2016/06/16
- fix issue #18 Minor issue with comment syntax
diff --git a/Makefile.PL b/Makefile.PL
index 4e5de5bd..9b5e3244 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -3,7 +3,7 @@ use warnings;
use ExtUtils::MakeMaker;
use Config;
-my @myobjs = map { s|.c$|$Config{obj_ext}|; $_ } (
+my @myobjs = map { s|.c$|$Config{obj_ext}|; $_ } grep { $_ !~ m|^src/ltc/\.*tab\.c$| } (
glob('src/ltm/*.c'),
glob('src/ltc/*/*.c'),
glob('src/ltc/*/*/*.c'),
diff --git a/src/ltc/ciphers/aes/aes.c b/src/ltc/ciphers/aes/aes.c
index 390f4374..cc9d99f3 100644
--- a/src/ltc/ciphers/aes/aes.c
+++ b/src/ltc/ciphers/aes/aes.c
@@ -89,7 +89,7 @@ const struct ltc_cipher_descriptor aes_enc_desc =
#endif
#define __LTC_AES_TAB_C__
-#include "aes_tab.c.inc"
+#include "aes_tab.c"
static ulong32 setup_mix(ulong32 temp)
{
diff --git a/src/ltc/ciphers/aes/aes_tab.c.inc b/src/ltc/ciphers/aes/aes_tab.c
index 9c902e88..9c902e88 100644
--- a/src/ltc/ciphers/aes/aes_tab.c.inc
+++ b/src/ltc/ciphers/aes/aes_tab.c
diff --git a/src/ltc/ciphers/safer/safer.c b/src/ltc/ciphers/safer/safer.c
index dca7b3a1..865eee3d 100644
--- a/src/ltc/ciphers/safer/safer.c
+++ b/src/ltc/ciphers/safer/safer.c
@@ -33,7 +33,7 @@
#ifdef LTC_SAFER
#define __LTC_SAFER_TAB_C__
-#include "safer_tab.c.inc"
+#include "safer_tab.c"
const struct ltc_cipher_descriptor
safer_k64_desc = {
diff --git a/src/ltc/ciphers/safer/safer_tab.c.inc b/src/ltc/ciphers/safer/safer_tab.c
index 308fe55b..308fe55b 100755
--- a/src/ltc/ciphers/safer/safer_tab.c.inc
+++ b/src/ltc/ciphers/safer/safer_tab.c
diff --git a/src/ltc/ciphers/safer/saferp.c b/src/ltc/ciphers/safer/saferp.c
index 27502402..e5f8bf39 100644
--- a/src/ltc/ciphers/safer/saferp.c
+++ b/src/ltc/ciphers/safer/saferp.c
@@ -18,7 +18,7 @@
#ifdef LTC_SAFERP
#define __LTC_SAFER_TAB_C__
-#include "safer_tab.c.inc"
+#include "safer_tab.c"
const struct ltc_cipher_descriptor saferp_desc =
{
diff --git a/src/ltc/ciphers/twofish/twofish.c b/src/ltc/ciphers/twofish/twofish.c
index 181d2e42..b443a7c1 100644
--- a/src/ltc/ciphers/twofish/twofish.c
+++ b/src/ltc/ciphers/twofish/twofish.c
@@ -63,7 +63,7 @@ static const unsigned char qord[4][5] = {
#ifdef LTC_TWOFISH_TABLES
#define __LTC_TWOFISH_TAB_C__
-#include "twofish_tab.c.inc"
+#include "twofish_tab.c"
#define sbox(i, x) ((ulong32)SBOX[i][(x)&255])
diff --git a/src/ltc/ciphers/twofish/twofish_tab.c.inc b/src/ltc/ciphers/twofish/twofish_tab.c
index 7ea85866..7ea85866 100755
--- a/src/ltc/ciphers/twofish/twofish_tab.c.inc
+++ b/src/ltc/ciphers/twofish/twofish_tab.c
diff --git a/src/ltc/hashes/whirl/whirl.c b/src/ltc/hashes/whirl/whirl.c
index 5e3da4c3..af5625a7 100644
--- a/src/ltc/hashes/whirl/whirl.c
+++ b/src/ltc/hashes/whirl/whirl.c
@@ -38,7 +38,7 @@ const struct ltc_hash_descriptor whirlpool_desc =
/* the sboxes */
#define __LTC_WHIRLTAB_C__
-#include "whirltab.c.inc"
+#include "whirltab.c"
/* get a_{i,j} */
#define GB(a,i,j) ((a[(i) & 7] >> (8 * (j))) & 255)
diff --git a/src/ltc/hashes/whirl/whirltab.c.inc b/src/ltc/hashes/whirl/whirltab.c
index bb4b77ab..bb4b77ab 100755
--- a/src/ltc/hashes/whirl/whirltab.c.inc
+++ b/src/ltc/hashes/whirl/whirltab.c
diff --git a/src/ltc/mac/pelican/pelican.c b/src/ltc/mac/pelican/pelican.c
index da06d340..8622f55f 100644
--- a/src/ltc/mac/pelican/pelican.c
+++ b/src/ltc/mac/pelican/pelican.c
@@ -20,7 +20,7 @@
#define __LTC_AES_TAB_C__
#define ENCRYPT_ONLY
#define PELI_TAB
-#include "../../ciphers/aes/aes_tab.c.inc"
+#include "../../ciphers/aes/aes_tab.c"
/**
Initialize a Pelican state
diff --git a/src/ltc/prngs/sober128.c b/src/ltc/prngs/sober128.c
index 4314cce6..25a3b43f 100644
--- a/src/ltc/prngs/sober128.c
+++ b/src/ltc/prngs/sober128.c
@@ -19,7 +19,7 @@
#ifdef LTC_SOBER128
#define __LTC_SOBER128TAB_C__
-#include "sober128tab.c.inc"
+#include "sober128tab.c"
const struct ltc_prng_descriptor sober128_desc =
{
diff --git a/src/ltc/prngs/sober128tab.c.inc b/src/ltc/prngs/sober128tab.c
index 74e4f880..74e4f880 100755
--- a/src/ltc/prngs/sober128tab.c.inc
+++ b/src/ltc/prngs/sober128tab.c