summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2021-11-12 16:41:47 +0100
committergregor herrmann <gregoa@debian.org>2021-11-12 16:41:47 +0100
commit45dbc0e95853e945a00ab7c9d92939010fd42f7e (patch)
tree7d27b44f6b44caf3fdebbe92dff79fcdb86f70da
parent38af24d9c258230317a99a43421a48ebe4294378 (diff)
parent48f8c4e1e192a000ade040200c576a04c247bd92 (diff)
Update upstream source from tag 'upstream/1.33'
Update to upstream version '1.33' with Debian dir 2f0899c8d30ff435be6f373c356e846d42ec329c
-rw-r--r--.gitignore23
-rw-r--r--Changes3
-rw-r--r--Firebird.pm2
-rw-r--r--Makefile.PL12
-rw-r--r--README.md14
5 files changed, 22 insertions, 32 deletions
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 912a44b..0000000
--- a/.gitignore
+++ /dev/null
@@ -1,23 +0,0 @@
-# Lines starting with '#' are considered comments.
-Makefile
-Makefile.old
-META.yml
-MYMETA.*
-pm_to_blib
-blib/
-*.tmp
-*~
-*.log
-*.bs
-*.o
-*.xsi
-Firebird.c
-t/tests-setup.tmp.*
-t/create.sql
-t/insert.sql
-t/test.conf
-
-var/*
-embed/
-t/embed-*
-fb_init
diff --git a/Changes b/Changes
index 40f9452..48c6d68 100644
--- a/Changes
+++ b/Changes
@@ -1,4 +1,7 @@
Revision history for Perl extension DBD::Firebird.
+1.33 [2021-11-9]
+ * Do not link with Firebird framework if it does not exist on macOS.
+This should fix issue #51.
1.32 [2020-03-11]
* Add support for COMMIT and ROLLBACK statements #48
1.31 [2017-12-05]
diff --git a/Firebird.pm b/Firebird.pm
index 7bf6c0e..dc3ac11 100644
--- a/Firebird.pm
+++ b/Firebird.pm
@@ -19,7 +19,7 @@ require Exporter;
require DynaLoader;
@ISA = qw(Exporter DynaLoader);
-$VERSION = '1.32';
+$VERSION = '1.33';
bootstrap DBD::Firebird $VERSION;
diff --git a/Makefile.PL b/Makefile.PL
index 7be4b5b..c6946fe 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -292,7 +292,17 @@ SWITCH: {
last SWITCH;
};
$os eq 'darwin' && do {
- $MakeParams{LDDLFLAGS} = $Config{lddlflags} . " -framework Firebird ";
+ my $framework_dir = dirname $FB::HOME; #"/Library/Frameworks/Firebird.framework";
+ my $framework_name = File::Spec->catfile( $framework_dir, "Firebird");
+ # For some reason, the framework file can be a broken symlink, see issue #??
+ # We can use -e to check if the symlink is broken:
+ if ( -e $framework_name ) {
+ $MakeParams{LDDLFLAGS} = $Config{lddlflags} . " -framework Firebird ";
+ }
+ else {
+ $MakeParams{LDDLFLAGS} = $Config{lddlflags};
+ $MakeParams{LIBS} = "-L$FB::LIB -l$client_lib ";
+ }
last SWITCH;
};
diff --git a/README.md b/README.md
index 7f34aa9..3e9e74a 100644
--- a/README.md
+++ b/README.md
@@ -1,11 +1,11 @@
-DBD::Firebird version 1.21
+DBD::Firebird version 1.32
==========================
DBI driver for the Firebird RDBMS server.
- Copyright © 2015 Stefan Roas
- Copyright © 2014 H.Merijn Brand - Tux
-- Copyright © 2010-2015 Popa Adrian Marius
+- Copyright © 2010-2020 Popa Adrian Marius
- Copyright © 2011-2013 Stefan Suciu
- Copyright © 2011-2015 Damyan Ivanov
- Copyright © 2011 Alexandr Ciornii
@@ -18,7 +18,7 @@ License
You may distribute under the terms of either the GNU General Public
License or the Artistic License, as specified in the Perl README file.
-(http://dev.perl.org/licenses/artistic.html)
+(https://dev.perl.org/licenses/artistic.html)
Installation
@@ -31,12 +31,12 @@ Requirements:
- Firebird (2.5.1 or higher)
- A C compiler
* UN*X
- GCC 4.x (tested, older may or may not work) or other capable
- clang
+ GCC or Clang
+
* Windows
- - Strawberry perl (http://strawberryperl.com/) comes with it's own compiler (mingw)
- - Visual Studio C++ (http://visualstudio.com)
+ - Strawberry perl (https://strawberryperl.com/) comes with it's own compiler (mingw)
+ - Visual Studio C++ (https://visualstudio.com)
- Cygwin
* Freebsd
- Threaded Perl is required (You have to re-install Perl from