summaryrefslogtreecommitdiff
path: root/debian/control.in
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control.in')
-rw-r--r--debian/control.in34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/control.in b/debian/control.in
new file mode 100644
index 0000000..9e9b1b7
--- /dev/null
+++ b/debian/control.in
@@ -0,0 +1,34 @@
+Source: libex-monkeypatched-perl
+Section: perl
+Priority: optional
+Build-Depends: @cdbs@, debhelper (>= 10~)
+Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
+Uploaders: Jonas Smedegaard <dr@jones.dk>
+Standards-Version: 3.9.6
+Vcs-Git: git://anonscm.debian.org/pkg-perl/packages/libex-monkeypatched-perl
+Vcs-Browser: https://anonscm.debian.org/cgit/pkg-perl/packages/libex-monkeypatched-perl.git
+Homepage: https://metacpan.org/release/ex-monkeypatched
+Testsuite: autopkgtest-pkg-perl
+
+Package: libex-monkeypatched-perl
+Architecture: all
+Depends: ${perl:Depends}, ${misc:Depends}, ${cdbs:Depends}
+Enhances: ${cdbs:Enhances}
+Description: experimental API for safe monkey-patching
+ The term "monkey patching" describes injecting additional methods into
+ a class whose implementation you don't control. If done without care,
+ this is dangerous; the problematic case arises when:
+ * You add a method to a class;
+ * A newer version of the monkey-patched class adds another method of
+ the same name
+ * And uses that new method in some other part of its own
+ implementation.
+ .
+ ex::monkeypatched lets you do this sort of monkey-patching safely:
+ before it injects a method into the target class, it checks whether the
+ class already has a method of the same name. If it finds such a
+ method, it throws an exception (at compile-time with respect to the
+ code that does the injection).
+ .
+ See <http://aaroncrane.co.uk/talks/monkey_patching_subclassing/> for
+ more details.