summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2019-11-02 02:50:12 +0100
committergregor herrmann <gregoa@debian.org>2019-11-02 02:50:12 +0100
commit48bc6f6795a64f590d49ef43728a4d469cd8802b (patch)
tree3992bccdd32cb80bde0a770e12303206c20392aa
parent395a158c7c9fb1b897b2c756d493115fad48da53 (diff)
parent680c782c4b24677940eb6f0d425e19a954bc04b0 (diff)
Update upstream source from tag 'upstream/1.10'
Update to upstream version '1.10' with Debian dir 8cf8e250a91c50d0db68c2cfbf289e1ff0ab2b15
-rw-r--r--Changes6
-rw-r--r--LICENSE2
-rw-r--r--META.json11
-rw-r--r--META.yml11
-rw-r--r--Makefile.PL2
-rw-r--r--README10
-rw-r--r--lib/Getopt/Lucid.pm16
-rw-r--r--lib/Getopt/Lucid/Exception.pm6
-rw-r--r--xt/author/minimum-version.t4
-rw-r--r--xt/author/pod-spell.t3
10 files changed, 44 insertions, 27 deletions
diff --git a/Changes b/Changes
index 08fde5c..51a719b 100644
--- a/Changes
+++ b/Changes
@@ -1,5 +1,11 @@
Revision history for Perl module Getopt::Lucid
+1.10 2019-10-25 17:12:54-04:00 America/New_York
+
+ [Docs]
+
+ - Fixed typo
+
1.09 2018-06-20 23:22:09-06:00 America/Denver
[Added]
diff --git a/LICENSE b/LICENSE
index a13ab7e..76552c1 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,4 +1,4 @@
-This software is Copyright (c) 2018 by David Golden.
+This software is Copyright (c) 2019 by David Golden.
This is free software, licensed under:
diff --git a/META.json b/META.json
index c670f6e..35de2db 100644
--- a/META.json
+++ b/META.json
@@ -85,11 +85,11 @@
"provides" : {
"Getopt::Lucid" : {
"file" : "lib/Getopt/Lucid.pm",
- "version" : "1.09"
+ "version" : "1.10"
},
"Getopt::Lucid::Exception" : {
"file" : "lib/Getopt/Lucid/Exception.pm",
- "version" : "1.09"
+ "version" : "1.10"
}
},
"release_status" : "stable",
@@ -104,9 +104,10 @@
"web" : "https://github.com/dagolden/Getopt-Lucid"
}
},
- "version" : "1.09",
+ "version" : "1.10",
"x_authority" : "cpan:DAGOLDEN",
"x_contributors" : [
+ "Chris White <cxwembedded@gmail.com>",
"David Golden <xdg@xdg.me>",
"David Precious <davidp@preshweb.co.uk>",
"James E Keenan <jkeenan@cpan.org>",
@@ -115,7 +116,7 @@
"Robert Bohne <rbo@cpan.org>",
"thilp <thilp@thilp.net>"
],
- "x_generated_by_perl" : "v5.26.1",
- "x_serialization_backend" : "Cpanel::JSON::XS version 3.0239"
+ "x_generated_by_perl" : "v5.30.0",
+ "x_serialization_backend" : "Cpanel::JSON::XS version 4.15"
}
diff --git a/META.yml b/META.yml
index 8bc3b16..3885ca3 100644
--- a/META.yml
+++ b/META.yml
@@ -32,10 +32,10 @@ no_index:
provides:
Getopt::Lucid:
file: lib/Getopt/Lucid.pm
- version: '1.09'
+ version: '1.10'
Getopt::Lucid::Exception:
file: lib/Getopt/Lucid/Exception.pm
- version: '1.09'
+ version: '1.10'
requires:
Carp: '0'
Exception::Class: '1.23'
@@ -50,9 +50,10 @@ resources:
bugtracker: https://github.com/dagolden/Getopt-Lucid/issues
homepage: https://github.com/dagolden/Getopt-Lucid
repository: https://github.com/dagolden/Getopt-Lucid.git
-version: '1.09'
+version: '1.10'
x_authority: cpan:DAGOLDEN
x_contributors:
+ - 'Chris White <cxwembedded@gmail.com>'
- 'David Golden <xdg@xdg.me>'
- 'David Precious <davidp@preshweb.co.uk>'
- 'James E Keenan <jkeenan@cpan.org>'
@@ -60,5 +61,5 @@ x_contributors:
- 'Nova Patch <patch@cpan.org>'
- 'Robert Bohne <rbo@cpan.org>'
- 'thilp <thilp@thilp.net>'
-x_generated_by_perl: v5.26.1
-x_serialization_backend: 'YAML::Tiny version 1.70'
+x_generated_by_perl: v5.30.0
+x_serialization_backend: 'YAML::Tiny version 1.73'
diff --git a/Makefile.PL b/Makefile.PL
index d30dc11..4a77a88 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -35,7 +35,7 @@ my %WriteMakefileArgs = (
"lib" => 0,
"vars" => 0
},
- "VERSION" => "1.09",
+ "VERSION" => "1.10",
"test" => {
"TESTS" => "t/*.t"
}
diff --git a/README b/README
index 0781d3d..f452941 100644
--- a/README
+++ b/README
@@ -2,7 +2,7 @@ NAME
Getopt::Lucid - Clear, readable syntax for command line processing
VERSION
- version 1.09
+ version 1.10
SYNOPSIS
use Getopt::Lucid qw( :all );
@@ -175,7 +175,7 @@ USAGE
@spec = (
Param("input")->default("/dev/random")->needs("output"),
- Param("output)->default("/dev/null"),
+ Param("output")->default("/dev/null"),
);
valid()
@@ -211,7 +211,7 @@ USAGE
@spec = (
Param("input")->needs("output"),
- Param("output),
+ Param("output"),
);
anycase()
@@ -668,6 +668,8 @@ AUTHOR
David Golden <dagolden@cpan.org>
CONTRIBUTORS
+ * Chris White <cxwembedded@gmail.com>
+
* David Golden <xdg@xdg.me>
* David Precious <davidp@preshweb.co.uk>
@@ -683,7 +685,7 @@ CONTRIBUTORS
* thilp <thilp@thilp.net>
COPYRIGHT AND LICENSE
- This software is Copyright (c) 2018 by David Golden.
+ This software is Copyright (c) 2019 by David Golden.
This is free software, licensed under:
diff --git a/lib/Getopt/Lucid.pm b/lib/Getopt/Lucid.pm
index b435d31..d426bdd 100644
--- a/lib/Getopt/Lucid.pm
+++ b/lib/Getopt/Lucid.pm
@@ -4,7 +4,7 @@ use warnings;
package Getopt::Lucid;
# ABSTRACT: Clear, readable syntax for command line processing
-our $VERSION = '1.09';
+our $VERSION = '1.10';
our @EXPORT_OK = qw(Switch Counter Param List Keypair);
our %EXPORT_TAGS = ( all => [ @EXPORT_OK ] );
@@ -881,7 +881,7 @@ Getopt::Lucid - Clear, readable syntax for command line processing
=head1 VERSION
-version 1.09
+version 1.10
=head1 SYNOPSIS
@@ -1087,7 +1087,7 @@ possible. E.g.:
@spec = (
Param("input")->default("/dev/random")->needs("output"),
- Param("output)->default("/dev/null"),
+ Param("output")->default("/dev/null"),
);
=head3 valid()
@@ -1126,7 +1126,7 @@ exception is thrown.
@spec = (
Param("input")->needs("output"),
- Param("output),
+ Param("output"),
);
=head3 anycase()
@@ -1675,12 +1675,16 @@ David Golden <dagolden@cpan.org>
=head1 CONTRIBUTORS
-=for stopwords David Golden Precious James E Keenan Kevin McGrath Nova Patch Robert Bohne thilp
+=for stopwords Chris White David Golden Precious James E Keenan Kevin McGrath Nova Patch Robert Bohne thilp
=over 4
=item *
+Chris White <cxwembedded@gmail.com>
+
+=item *
+
David Golden <xdg@xdg.me>
=item *
@@ -1711,7 +1715,7 @@ thilp <thilp@thilp.net>
=head1 COPYRIGHT AND LICENSE
-This software is Copyright (c) 2018 by David Golden.
+This software is Copyright (c) 2019 by David Golden.
This is free software, licensed under:
diff --git a/lib/Getopt/Lucid/Exception.pm b/lib/Getopt/Lucid/Exception.pm
index f88ae2e..f6cf91d 100644
--- a/lib/Getopt/Lucid/Exception.pm
+++ b/lib/Getopt/Lucid/Exception.pm
@@ -4,7 +4,7 @@ use warnings;
package Getopt::Lucid::Exception;
# ABSTRACT: Exception classes for Getopt::Lucid
-our $VERSION = '1.09';
+our $VERSION = '1.10';
use Exporter;
our @ISA = qw/Exporter Exception::Class::Base/;
@@ -55,7 +55,7 @@ Getopt::Lucid::Exception - Exception classes for Getopt::Lucid
=head1 VERSION
-version 1.09
+version 1.10
=for Pod::Coverage description
throw_argv
@@ -68,7 +68,7 @@ David Golden <dagolden@cpan.org>
=head1 COPYRIGHT AND LICENSE
-This software is Copyright (c) 2018 by David Golden.
+This software is Copyright (c) 2019 by David Golden.
This is free software, licensed under:
diff --git a/xt/author/minimum-version.t b/xt/author/minimum-version.t
index d4a20c3..92c8f75 100644
--- a/xt/author/minimum-version.t
+++ b/xt/author/minimum-version.t
@@ -1,6 +1,6 @@
-#!perl
+use strict;
+use warnings;
use Test::More;
-
use Test::MinimumVersion;
all_minimum_version_ok( qq{5.010} );
diff --git a/xt/author/pod-spell.t b/xt/author/pod-spell.t
index 9a2c71a..8ff861b 100644
--- a/xt/author/pod-spell.t
+++ b/xt/author/pod-spell.t
@@ -11,6 +11,7 @@ add_stopwords(<DATA>);
all_pod_files_spelling_ok( qw( bin lib ) );
__DATA__
Bohne
+Chris
David
Exception
Getopt
@@ -24,6 +25,8 @@ Nova
Patch
Precious
Robert
+White
+cxwembedded
dagolden
davidp
getopt