summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Haber <mh+debian-packages@zugschlus.de>2023-12-09 22:41:53 +0100
committergregor herrmann <gregoa@debian.org>2023-12-09 22:41:53 +0100
commitd1e7c8de8353b1e15a5ee5c137c2a8bedec8bfd3 (patch)
tree295b7160b82c2ac296b50c64ee1f73c68eb9a2ad
parentcfefaa401db1a5157da10b71f25108bf078d68a2 (diff)
This patch makes the upstream source use the locally delivered
Bug: https://github.com/jacquesg/p5-Git-Raw/issues/195 Reviewed-by: gregor herrmann <gregoa@debian.org> Last-Update: 2022-10-29 libraries instead of the convenience copies of compatible libs included in the upstream tarball. Since libgit has not declared a stable interface, upstream didn't bother to make the code fall back to the system versions of the libs and rejected the respective issue. Gbp-Pq: Name remove-convenience-libs
-rw-r--r--Makefile.PL3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index d430e0fb..49bdf741 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -251,6 +251,7 @@ my @deps = glob 'deps/libgit2/deps/{http-parser,zlib,pcre}/*.c';
my @srcs = glob 'deps/libgit2/src/libgit2/{*.c,transports/*.c,xdiff/*.c,streams/*.c}';
push @srcs, glob 'deps/libgit2/src/util/{*.c,allocators/*.c,hash/collision*.c,hash/hash*.c,hash/builtin*.c,hash/sha1dc/*.c,hash/rfc6234/*.c}';
$inc .= ' -Ideps/libgit2/deps/pcre';
+$lib .= ' -lgit2';
if ($is_windows) {
push @srcs, glob 'deps/libgit2/src/util/win32/*.c';
@@ -336,7 +337,7 @@ my %WriteMakefileArgs = (
"Getopt::Long" => "2.35"
},
"DISTNAME" => "Git-Raw",
- "INC" => "-I. -Ideps/libgit2 -I deps/libgit2/include -Ideps/libgit2/src/libgit2 -Ideps/libgit2/src/util -Ideps/libgit2/deps/http-parser -Ideps/libgit2/deps/zlib",
+ "INC" => "-I. ",
"LICENSE" => "perl",
"MIN_PERL_VERSION" => "5.006",
"NAME" => "Git::Raw",