summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@atheme.org>2010-07-02 06:05:27 -0500
committerWilliam Pitcock <nenolod@atheme.org>2010-07-02 06:05:27 -0500
commite6e0ce5529a2410dec4a1cf44d7004c545b49ac9 (patch)
treedd30be54091ce31adb858f76e69f38714e43137e /Makefile
Import libguess (based on audacious sources).
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1b7b5f8
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,23 @@
+SUBDIRS = src
+DISTCLEAN = extra.mk buildsys.mk config.log config.status libguess.pc
+
+include buildsys.mk
+
+install-extra:
+ i="libguess.pc"; \
+ ${INSTALL_STATUS}; \
+ if ${MKDIR_P} ${DESTDIR}${libdir}/pkgconfig && ${INSTALL} -m 644 $$i ${DESTDIR}${libdir}/pkgconfig/$$i; then \
+ ${INSTALL_OK}; \
+ else \
+ ${INSTALL_FAILED}; \
+ fi
+
+uninstall-extra:
+ i="libguess.pc"; \
+ if [ -f ${DESTDIR}${libdir}/pkgconfig/$$i ]; then \
+ if rm -f ${DESTDIR}${libdir}/pkgconfig/$$i; then \
+ ${DELETE_OK}; \
+ else \
+ ${DELETE_FAILED}; \
+ fi \
+ fi