summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@atheme.org>2010-07-02 06:05:27 -0500
committerWilliam Pitcock <nenolod@atheme.org>2010-07-02 06:05:27 -0500
commite6e0ce5529a2410dec4a1cf44d7004c545b49ac9 (patch)
treedd30be54091ce31adb858f76e69f38714e43137e /configure.ac
Import libguess (based on audacious sources).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac72
1 files changed, 72 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f63f80e
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,72 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT([libguess], [1.0], [bugs+libguess@atheme.org])
+AC_CONFIG_SRCDIR([src/libguess/guess.c])
+AC_CONFIG_HEADER([src/libguess/autoconf.h])
+
+AC_CANONICAL_HOST
+AC_CANONICAL_TARGET
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_LN_S
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+AC_ISC_POSIX
+
+test x"$GCC" = x"yes" && CFLAGS="$CFLAGS -pipe -Wall"
+
+# XXX workaround
+PACKAGE="libguess"
+AC_SUBST(PACKAGE)
+
+# Checks for libraries.
+BUILDSYS_SHARED_LIB
+LIBS="$LIBS $DYNAMIC_LD_LIBS"
+
+# Checks for header files.
+AC_HEADER_DIRENT
+AC_HEADER_STDC
+AC_CHECK_HEADERS([limits.h stdlib.h string.h unistd.h locale.h stdarg.h sys/types.h sys/stat.h errno.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+
+# Checks for library functions.
+AC_FUNC_CLOSEDIR_VOID
+AC_CHECK_FUNCS([memset setlocale strcasecmp strchr strdup strerror strtol strtod])
+AC_CHECK_FUNCS([printf sprintf snprintf vsnprintf gettimeofday strndup strlcpy strlcat])
+AC_FUNC_STAT
+
+PKG_CHECK_MODULES([MOWGLI], [libmowgli >= 0.7.0], [], [AC_MSG_ERROR([Install Mowgli from http://atheme.org/projects/mowgli.])])
+
+# Check for optional features.
+EXAMPLES_BUILD=""
+AC_ARG_ENABLE(examples,
+ [ --enable-examples build and install example programs],
+ [enable_examples=$enableval],
+ [enable_examples="no"]
+)
+
+if test "x$enable_examples" = "xyes"; then
+ EXAMPLES_BUILD="examples"
+fi
+
+AC_SUBST(EXAMPLES_BUILD)
+
+BUILDSYS_TOUCH_DEPS
+
+AC_CONFIG_FILES([buildsys.mk extra.mk libguess.pc])
+AC_OUTPUT
+
+cat << _EOF_
+
+Configuration:
+ No special features yet.
+
+Now type "make" to build, and "make install" to install.
+Thank you for using libguess.
+
+_EOF_