summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2014-06-21 14:20:53 +0200
committerAndrew Shadura <andrew@shadura.me>2014-06-21 14:20:53 +0200
commit04a5b2f0abf3ac30ea0c294eac027bf610bfd171 (patch)
tree27db540e33ddc7285be4fb2de4da10e5310a1412 /debian
parent01331f8ef91978230a44e9307cd66007261eb417 (diff)
Update to the latest upstream snapshot
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog15
-rw-r--r--debian/clean1
-rw-r--r--debian/control12
-rwxr-xr-xdebian/get-orig-source.sh36
-rw-r--r--debian/patches/01-change-mowgli-requirement.diff15
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules16
7 files changed, 76 insertions, 20 deletions
diff --git a/debian/changelog b/debian/changelog
index a586d1c..34e3122 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+libguess (1.2~git20131128.cc43cefc-1) unstable; urgency=medium
+
+ * Update to the latest upstream snapshot.
+ * Add pkg-config dependency.
+
+ -- Andrew Shadura <andrewsh@debian.org> Sat, 21 Jun 2014 14:26:27 +0200
+
+libguess (1.1-4) unstable; urgency=low
+
+ * Update config.sub and config.guess on build.
+ * Build-depend on autotools-dev to have fresh config.* files.
+ * Update Standards-Version.
+
+ -- Andrew Shadura <andrewsh@debian.org> Mon, 27 Jan 2014 19:52:50 +0100
+
libguess (1.1-3) unstable; urgency=low
* Remove myself from Uploaders.
diff --git a/debian/clean b/debian/clean
index f1e469b..958d57b 100644
--- a/debian/clean
+++ b/debian/clean
@@ -1 +1,2 @@
.deps src/.deps src/*/.deps src/libguess/guess_tab.c buildsys.mk config.log config.status extra.mk libguess.pc src/libguess/autoconf.h src/libguess/libguess.so.1
+config.sub config.guess configure aclocal.m4
diff --git a/debian/control b/debian/control
index e81e6a8..da2ee1e 100644
--- a/debian/control
+++ b/debian/control
@@ -1,8 +1,14 @@
Source: libguess
Priority: optional
Maintainer: Andrew Shadura <andrewsh@debian.org>
-Build-Depends: debhelper (>= 9), dh-autoreconf, libmowgli-dev (>= 0.7.0), pkg-config, gauche
-Standards-Version: 3.9.4
+Build-Depends:
+ debhelper (>= 9),
+ dh-autoreconf,
+ libmowgli-2-dev,
+ pkgconf | pkg-config,
+ gauche,
+ autotools-dev
+Standards-Version: 3.9.5
Section: libs
Homepage: http://www.atheme.org/project/libguess
Vcs-hg: http://hg.debian.org/hg/collab-maint/libguess
@@ -11,7 +17,7 @@ Vcs-Browser: http://hg.debian.org/hg/collab-maint/libguess/summary
Package: libguess-dev
Section: libdevel
Architecture: any
-Depends: libguess1 (= ${binary:Version}), ${misc:Depends}, libmowgli-dev (>= 0.7.0)
+Depends: libguess1 (= ${binary:Version}), ${misc:Depends}, libmowgli-2-dev, pkgconf | pkg-config
Multi-Arch: same
Description: high-speed character set detection library (development)
libguess employs discrete-finite automata to deduce the character set of the
diff --git a/debian/get-orig-source.sh b/debian/get-orig-source.sh
new file mode 100755
index 0000000..12f6b80
--- /dev/null
+++ b/debian/get-orig-source.sh
@@ -0,0 +1,36 @@
+#!/bin/sh -e
+
+# run with GIT_REVISION set to check out a new tarball
+
+UPSTREAM_REPO=git://github.com/atheme/libguess.git
+TARBALLDIR=${1:-.}
+WDIR=debian/orig-source
+rm -rf ${WDIR}
+mkdir ${WDIR}
+
+set -- $(head -n1 debian/changelog | tr -d '()')
+
+PACKAGE=$1
+VERSION=$2
+SRC_VERSION=${2%%-*}
+if [ -z "$GIT_REVISION" ]
+then
+ TARBALLNAME=${PACKAGE}_${SRC_VERSION}
+ GIT_REVISION=${SRC_VERSION##*.}
+fi
+
+rm -rf debian/orig-source
+mkdir debian/orig-source
+
+git clone -n ${UPSTREAM_REPO} debian/orig-source/
+export GIT_DIR=debian/orig-source/.git
+if [ -z "$TARBALLNAME" ]
+then
+ DATE=$(date +%Y%m%d -d @$(git log ${GIT_REVISION} -1 --pretty=format:%ct))
+ TARBALLNAME=${PACKAGE}_${SRC_VERSION%%+*}+git${DATE}.$(echo ${GIT_REVISION}| cut -b 1-8)
+fi
+git archive -o ${TARBALLDIR}/${TARBALLNAME}.orig.tar --prefix=${TARBALLNAME}/ ${GIT_REVISION}
+bzip2 ${TARBALLDIR}/${TARBALLNAME}.orig.tar
+
+rm -rf debian/orig-source
+
diff --git a/debian/patches/01-change-mowgli-requirement.diff b/debian/patches/01-change-mowgli-requirement.diff
deleted file mode 100644
index a2664dd..0000000
--- a/debian/patches/01-change-mowgli-requirement.diff
+++ /dev/null
@@ -1,15 +0,0 @@
-Description: No need in 0.9.50 libmowgli, 0.7.0 is enough
-Author: Andrew O. Shadura <bugzilla@tut.by>
-
-diff --git a/configure.ac b/configure.ac
---- a/configure.ac
-+++ b/configure.ac
-@@ -40,7 +40,7 @@
- AC_CHECK_FUNCS([printf sprintf snprintf vsnprintf gettimeofday strndup strlcpy strlcat])
- AC_FUNC_STAT
-
--PKG_CHECK_MODULES([MOWGLI], [libmowgli >= 0.9.50], [], [AC_MSG_ERROR([Install Mowgli from http://atheme.org/project/mowgli.])])
-+PKG_CHECK_MODULES([MOWGLI], [libmowgli >= 0.7.0], [], [AC_MSG_ERROR([Install Mowgli from http://atheme.org/project/mowgli.])])
-
- # Check for optional features.
- EXAMPLES_BUILD=""
diff --git a/debian/patches/series b/debian/patches/series
index b6a642a..a48ced7 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1 @@
00-remove-colours.diff
-01-change-mowgli-requirement.diff
diff --git a/debian/rules b/debian/rules
index 887215c..eef6fc0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,15 @@ export ACLOCAL := aclocal -I m4
%:
dh $@ --with=autoreconf
+override_dh_auto_configure:
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+ dh_auto_configure -- SHELL=/bin/sh
+
override_dh_auto_build:
gosh src/libguess/guess.scm src/libguess/guess_tab.c
dh_auto_build
@@ -25,4 +34,9 @@ ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
LD_LIBRARY_PATH=$(LD_LIBRARY_PATH):$(CURDIR)/src/libguess make -C src/tests/testbench --no-print-directory run
endif
-.PHONY: override_dh_auto_build override_dh_compress override_dh_auto_clean override_dh_auto_test
+get-orig-source:
+ @d=$$(readlink -e $(MAKEFILE_LIST)); \
+ cd $${d%/*}/..; \
+ debian/get-orig-source.sh $(CURDIR)
+
+.PHONY: override_dh_auto_clean override_dh_auto_configure override_dh_auto_build override_dh_compress override_dh_auto_test get-orig-source