summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrew O. Shadoura <bugzilla@tut.by>2011-03-19 23:25:36 +0200
committerAndrew O. Shadoura <bugzilla@tut.by>2011-03-19 23:25:36 +0200
commit8b09fa80e3920cbd3bb2e39aa86c0fc9b40183e5 (patch)
treefdd2c485ccbaf486b91691cd2843611144f8fa74 /debian
parent47739f3c908a9a2cda1395bc8c8f6a5488727277 (diff)
remove colour escape sequences from the output
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/00-remove-colours.diff43
-rw-r--r--debian/patches/series1
2 files changed, 44 insertions, 0 deletions
diff --git a/debian/patches/00-remove-colours.diff b/debian/patches/00-remove-colours.diff
new file mode 100644
index 0000000..e22efed
--- /dev/null
+++ b/debian/patches/00-remove-colours.diff
@@ -0,0 +1,43 @@
+Description: Remove colour escape sequences from the output
+Author: Andrew O. Shadoura <bugzilla@tut.by>
+
+--- a/buildsys.mk.in
++++ b/buildsys.mk.in
+@@ -473,21 +473,21 @@
+ fi \
+ done
+
+-DIR_ENTER = printf "\033[K\033[0;36mEntering directory \033[1;36m$$i\033[0;36m.\033[0m\n"; cd $$i || exit 1
+-DIR_LEAVE = printf "\033[K\033[0;36mLeaving directory \033[1;36m$$i\033[0;36m.\033[0m\n"; cd .. || exit 1
+-DEPEND_STATUS = printf "\033[K\033[0;33mGenerating dependencies...\033[0m\r"
+-DEPEND_OK = printf "\033[K\033[0;32mSuccessfully generated dependencies.\033[0m\n"
+-DEPEND_FAILED = printf "\033[K\033[0;31mFailed to generate dependencies!\033[0m\n"; exit 1
+-COMPILE_STATUS = printf "\033[K\033[0;33mCompiling \033[1;33m$<\033[0;33m...\033[0m\r"
+-COMPILE_OK = printf "\033[K\033[0;32mSuccessfully compiled \033[1;32m$<\033[0;32m.\033[0m\n"
+-COMPILE_FAILED = printf "\033[K\033[0;31mFailed to compile \033[1;31m$<\033[0;31m!\033[0m\n"; exit 1
+-LINK_STATUS = printf "\033[K\033[0;33mLinking \033[1;33m$@\033[0;33m...\033[0m\r"
+-LINK_OK = printf "\033[K\033[0;32mSuccessfully linked \033[1;32m$@\033[0;32m.\033[0m\n"
+-LINK_FAILED = printf "\033[K\033[0;31mFailed to link \033[1;31m$@\033[0;31m!\033[0m\n"; exit 1
+-INSTALL_STATUS = printf "\033[K\033[0;33mInstalling \033[1;33m$$i\033[0;33m...\033[0m\r"
+-INSTALL_OK = printf "\033[K\033[0;32mSuccessfully installed \033[1;32m$$i\033[0;32m.\033[0m\n"
+-INSTALL_FAILED = printf "\033[K\033[0;31mFailed to install \033[1;31m$$i\033[0;31m!\033[0m\n"; exit 1
+-DELETE_OK = printf "\033[K\033[0;34mDeleted \033[1;34m$$i\033[0;34m.\033[0m\n"
+-DELETE_FAILED = printf "\033[K\033[0;31mFailed to delete \033[1;31m$$i\033[0;31m!\033[0m\n"; exit 1
++DIR_ENTER = printf "Entering directory $$i.\n"; cd $$i || exit 1
++DIR_LEAVE = printf "Leaving directory $$i.\n"; cd .. || exit 1
++DEPEND_STATUS = printf "Generating dependencies...\n"
++DEPEND_OK = printf "Successfully generated dependencies.\n"
++DEPEND_FAILED = printf "Failed to generate dependencies!\n"; exit 1
++COMPILE_STATUS = printf "Compiling $<...\n"
++COMPILE_OK = printf "Successfully compiled $<.\n"
++COMPILE_FAILED = printf "Failed to compile $<!\n"; exit 1
++LINK_STATUS = printf "Linking $@...\n"
++LINK_OK = printf "Successfully linked $@.\n"
++LINK_FAILED = printf "Failed to link $@!\n"; exit 1
++INSTALL_STATUS = printf "Installing $$i...\n"
++INSTALL_OK = printf "Successfully installed $$i.\n"
++INSTALL_FAILED = printf "Failed to install $$i!\n"; exit 1
++DELETE_OK = printf "Deleted $$i.\n"
++DELETE_FAILED = printf "Failed to delete $$i!\n"; exit 1
+
+ include .deps
diff --git a/debian/patches/series b/debian/patches/series
index cf57d64..c86d5de 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
+00-remove-colours.diff
01-fix-typo-on-mowgli-url.hg219e1937b9f5.diff
02-use-proper-format-string.diff
03-use-format.diff