summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..1825b4a
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,49 @@
+##
+## Process this file with automake to produce Makefile.in
+##
+
+AUTOMAKE_OPTIONS = 1.3
+
+SUBDIRS = docs m4 src
+
+EXTRA_DIST = AUTHORS COPYING ChangeLog FreeBSD-HOWTO NetBSD-HOWTO \
+ INSTALL INSTALL.french NEWS README README.french \
+ autogen.sh ibtk.spec.header ibtk.spec.in SlackBuild.in
+
+
+###
+
+spec:
+ @echo "Create new ibtk.spec.in."; \
+ cat ibtk.spec.header > ibtk.spec.in; \
+ echo "* `date +"%a %b %d %Y"` `id -un`" >> ibtk.spec.in; \
+ cat ChangeLog >> ibtk.spec.in
+
+
+mostlyclean-generic:
+ -rm -f *~ \#* .*~ .\#* $(PACKAGE).tgz \
+ package_descriptions $(PACKAGE)-$(VERSION).tar.gz
+
+
+
+maintainer-clean-generic:
+ -@echo "This command is intended for maintainers to use;"
+ -@echo "it deletes files that may require special tools to rebuild."
+ -rm -f Makefile.in
+
+
+dist-rpm: dist
+ @echo "Preparing source tarball to build a rpm packages..."; \
+ mv -f @TAR_NAME@.tar.gz ../../SOURCES; \
+ rpm -bb ibtk.spec; \
+ echo "done"
+
+
+dist-slack: all install
+ @./SlackBuild
+
+
+##
+## End of Makefile.am
+##
+###############################################################################