summaryrefslogtreecommitdiff
path: root/ibtk.spec.in
diff options
context:
space:
mode:
Diffstat (limited to 'ibtk.spec.in')
-rw-r--r--ibtk.spec.in121
1 files changed, 121 insertions, 0 deletions
diff --git a/ibtk.spec.in b/ibtk.spec.in
new file mode 100644
index 0000000..6165036
--- /dev/null
+++ b/ibtk.spec.in
@@ -0,0 +1,121 @@
+# Note that this is NOT a relocatable package
+%define ver @SPEC_VERSION@
+%define rel @SPEC_CVS_VERSION@
+%define prefix @prefix@
+
+Name: ibtk
+Summary: Insomnia's Basic ToolKit
+Version: %ver
+Release: %rel
+Copyright: GPL
+Group: Development/Libraries
+Source0: http://www.core.binghamton.edu/~insomnia/gatos/@TAR_NAME@
+Source1: @TAR_NAME@.tar.gz
+URL: http://www.core.binghamton.edu/~insomnia/gatos/
+
+%description
+Basic toolkit for gatos
+
+%setup -b 1 -T
+
+%build
+cd ../SOURCES
+tar xzvf @TAR_NAME@.tar.gz
+cd @TAR_NAME@
+./configure
+make
+
+%install
+cd @TAR_NAME@
+make install
+
+%clean
+cd ../SOURCES
+rm -rf @TAR_NAME@
+
+%files
+%{prefix}/include/ibtk/*
+%{prefix}/lib/libibtk.a
+%{prefix}/lib/libibtk.la
+## %{prefix}/lib/libibtk.so.@IBTK_MAJOR_VERSION@.@IBTK_MINOR_VERSION@.@IBTK_SUB_VERSION@
+
+%changelog
+
+* Mon Dec 20 1999 insomnia
+Version 0.0.14 released:
+
+ -Minor bugfixes.
+ -Renamed itk to ibtk (libitk -> libibtk).
+ -Added IBTK version.h defines.
+ -Added doublclick callback to IWindow.
+ -Added ELEMENT_SKIP support to IIntBox.
+ -Added IIntBox ElementFlags support.
+ -Added iconwindow support.
+ -Added IBTK_WRAP support to IIntBox.
+ -Started adding /etc/ibtk.conf support.
+ -Added IDoDad flags support.
+ -Added IBTK idle support (ActivityCallback).
+ -Added ClickCallback support.
+ -Fixed icon-name issue with IWindow.
+ -Added generic hook support.
+ -Fixed egcs compile with iintbox and irealbox callbacks.
+ -Added DragCallback support.
+ -Added ReleaseCallback support.
+
+Version 0.0.13 released:
+
+ -Various bugfixes.
+
+Version 0.0.12 released:
+
+ -Fixed Enter/Backspace fix.
+
+Version 0.0.11 released:
+
+ -Fixed Enter/Backspace issues.
+
+Version 0.0.10 released:
+
+ -Fixed hide bug in ITextBox.
+
+Version 0.0.9 released:
+
+ -Various Documentation updates.
+
+Version 0.0.8 released:
+
+ -IBox and IIntBox annoyances reduced.
+ -A few bugfixes.
+
+Version 0.0.7 released:
+
+ -Full "make install" support, and proper #includes.
+
+Version 0.0.6 released:
+
+ -Unhandledcallback now called for all unhandled events.
+ (Thanks to Øyvind Aabling).
+
+Version 0.0.5 released:
+
+ -Fixed keydown bug in IBox.
+ -Fixed reposition bug.
+ -Receive Visibility events (dumped to unhandledcallback).
+
+Version 0.0.4 released:
+
+ -Temporary fix for segfault int IListBox::Init()
+
+Version 0.0.3 released:
+
+ -Fixed issue with blank window titles.
+
+Version 0.0.2 released:
+
+ -Fixed unable to open DISPLAY segfault.
+ -Fixed many hide/show and redraw issues.
+ -Added mouse cursor positioning in boxes.
+
+Version 0.0.1 released:
+
+ -First public release.