summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am123
1 files changed, 123 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..1537df5
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,123 @@
+##
+## Process this file with automake to produce Makefile.in
+##
+
+##
+## Options for automake
+##
+AUTOMAKE_OPTIONS = no-dependencies foreign
+
+CXXFLAGS = -s -Wall @X_CFLAGS@
+
+X_X11_LIB = @X_X11_LIB@
+
+## INCLUDES = -I. -I../
+
+DEFS = -DCONFIGFILE=\"$(sysconfdir)/ibtk.conf\"
+
+##
+## Binary program that will NOT be install
+##
+EXTRA_PROGRAMS = main
+
+##
+## IBTK library
+##
+lib_LTLIBRARIES = libibtk.la
+libibtk_la_SOURCES = \
+ ibox.cpp \
+ ibutton.cpp \
+ idialogs.cpp \
+ igbox.cpp \
+ iintbox.cpp \
+ ilistbox.cpp \
+ irealbox.cpp \
+ isbutton.cpp \
+ islider.cpp \
+ istatbar.cpp \
+ itextbox.cpp \
+ iversion.cpp \
+ iwindow.cpp
+libibtk_la_LDFLAGS = -version-info $(IBTK_MAJOR_VERSION):$(IBTK_SUB_VERSION):$(IBTK_MINOR_VERSION)
+
+##
+## IBTK header files (must be installed)
+##
+include_HEADERS =\
+ ibox.h \
+ ibutton.h \
+ idialogs.h \
+ idodad.h \
+ igbox.h \
+ iintbox.h \
+ ilistbox.h \
+ irealbox.h \
+ isbutton.h \
+ islider.h \
+ istatbar.h \
+ itextbox.h \
+ iwindow.h \
+ pclaim.h \
+ version.h
+
+
+##
+## Test program (not be installed)
+##
+main_SOURCES = \
+ main.cpp
+main_LDADD = libibtk.la $(X_LIBS) $(X_X11_LIB)
+
+
+##
+##
+##
+
+
+##
+## Compile the test program
+##
+test: main
+
+
+##
+## Install header files (default=/usr/local/include/ibtk)
+##
+install-includeHEADERS: $(include_HEADERS)
+ @$(NORMAL_INSTALL)
+ $(mkinstalldirs) $(DESTDIR)$(includedir)/ibtk
+ @list='$(include_HEADERS)'; for p in $$list; do \
+ if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
+ echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(includedir)/ibtk/$$p"; \
+ $(INSTALL_DATA) $$d$$p $(DESTDIR)$(includedir)/ibtk/$$p; \
+ done
+
+
+##
+## Remove them
+##
+uninstall-includeHEADERS:
+ @$(NORMAL_UNINSTALL)
+ list='$(include_HEADERS)'; for p in $$list; do \
+ rm -f $(DESTDIR)$(includedir)/ibtk/$$p; \
+ done
+
+
+clean-generic:
+ -rm -f main
+
+
+mostlyclean-generic:
+ -rm -f *~ \#* .*~ .\#*
+
+
+maintainer-clean-generic:
+ -@echo "This command is intended for maintainers to use;"
+ -@echo "it deletes files that may require special tools to rebuild."
+ -rm -f Makefile.in
+
+##
+## End of Makefile.am
+##
+###############################################################################
+