summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2020-08-19 18:11:06 +0200
committergregor herrmann <gregoa@debian.org>2020-08-19 18:11:06 +0200
commita5b22bc211256133b7620c5bf7db5718ae8601d7 (patch)
tree554e2f467d7c38ac9eabecdb1337d88fe1a30d25
parent4fdfe0fac1b6eaf95cbf41b6c9e44fcf72f456d7 (diff)
parentc4997aba768ce20feed821a970a073cf7b9e0784 (diff)
Update upstream source from tag 'upstream/0.026'
Update to upstream version '0.026' with Debian dir a9e83fd3d30f5370cb5b153d07a51e6ca0c38b6c
-rw-r--r--Changes4
-rw-r--r--LICENSE6
-rw-r--r--MANIFEST2
-rw-r--r--META.json8
-rw-r--r--META.yml8
-rw-r--r--Makefile.PL4
-rw-r--r--cpanfile3
-rw-r--r--lib/Importer.pm4
8 files changed, 25 insertions, 14 deletions
diff --git a/Changes b/Changes
index aa751ae..55d3de1 100644
--- a/Changes
+++ b/Changes
@@ -1,3 +1,7 @@
+0.026 2020-08-16 14:24:02-07:00 America/Los_Angeles
+
+ - Work with strict on by default
+
0.025 2018-02-18 12:42:37-08:00 America/Los_Angeles
- Minor cperl fix
diff --git a/LICENSE b/LICENSE
index cc3439a..caa7d07 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,4 +1,4 @@
-This software is copyright (c) 2018 by Chad Granum.
+This software is copyright (c) 2020 by Chad Granum.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
@@ -12,7 +12,7 @@ b) the "Artistic License"
--- The GNU General Public License, Version 1, February 1989 ---
-This software is Copyright (c) 2018 by Chad Granum.
+This software is Copyright (c) 2020 by Chad Granum.
This is free software, licensed under:
@@ -272,7 +272,7 @@ That's all there is to it!
--- The Artistic License 1.0 ---
-This software is Copyright (c) 2018 by Chad Granum.
+This software is Copyright (c) 2020 by Chad Granum.
This is free software, licensed under:
diff --git a/MANIFEST b/MANIFEST
index 17622d5..ec26b5c 100644
--- a/MANIFEST
+++ b/MANIFEST
@@ -1,4 +1,4 @@
-# This file was automatically generated by Dist::Zilla::Plugin::Manifest v6.010.
+# This file was automatically generated by Dist::Zilla::Plugin::Manifest v6.015.
Changes
LICENSE
MANIFEST
diff --git a/META.json b/META.json
index bf58809..4870be1 100644
--- a/META.json
+++ b/META.json
@@ -4,7 +4,7 @@
"Chad Granum <exodist@cpan.org>"
],
"dynamic_config" : 0,
- "generated_by" : "Dist::Zilla version 6.010, CPAN::Meta::Converter version 2.150010",
+ "generated_by" : "Dist::Zilla version 6.015, CPAN::Meta::Converter version 2.150010",
"license" : [
"perl_5"
],
@@ -45,7 +45,9 @@
"url" : "http://github.com/exodist/Importer/"
}
},
- "version" : "0.025",
- "x_serialization_backend" : "Cpanel::JSON::XS version 4.00"
+ "version" : "0.026",
+ "x_generated_by_perl" : "v5.30.2",
+ "x_serialization_backend" : "Cpanel::JSON::XS version 4.19",
+ "x_spdx_expression" : "Artistic-1.0-Perl OR GPL-1.0-or-later"
}
diff --git a/META.yml b/META.yml
index a61e7bc..77b496f 100644
--- a/META.yml
+++ b/META.yml
@@ -7,7 +7,7 @@ build_requires:
configure_requires:
ExtUtils::MakeMaker: '0'
dynamic_config: 0
-generated_by: 'Dist::Zilla version 6.010, CPAN::Meta::Converter version 2.150010'
+generated_by: 'Dist::Zilla version 6.015, CPAN::Meta::Converter version 2.150010'
license: perl
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.4.html
@@ -18,5 +18,7 @@ requires:
resources:
bugtracker: http://github.com/exodist/Importer/issues
repository: http://github.com/exodist/Importer/
-version: '0.025'
-x_serialization_backend: 'YAML::Tiny version 1.70'
+version: '0.026'
+x_generated_by_perl: v5.30.2
+x_serialization_backend: 'YAML::Tiny version 1.73'
+x_spdx_expression: 'Artistic-1.0-Perl OR GPL-1.0-or-later'
diff --git a/Makefile.PL b/Makefile.PL
index 89983fe..c28f82f 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,4 +1,4 @@
-# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.010.
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.015.
use strict;
use warnings;
@@ -20,7 +20,7 @@ my %WriteMakefileArgs = (
"TEST_REQUIRES" => {
"Test::More" => "0.98"
},
- "VERSION" => "0.025",
+ "VERSION" => "0.026",
"test" => {
"TESTS" => "t/*.t"
}
diff --git a/cpanfile b/cpanfile
index a997856..28108ef 100644
--- a/cpanfile
+++ b/cpanfile
@@ -1,3 +1,6 @@
+# This file is generated by Dist::Zilla::Plugin::CPANFile v6.015
+# Do not edit this file directly. To change prereqs, edit the `dist.ini` file.
+
requires "perl" => "5.008001";
on 'test' => sub {
diff --git a/lib/Importer.pm b/lib/Importer.pm
index c07ec46..f10aada 100644
--- a/lib/Importer.pm
+++ b/lib/Importer.pm
@@ -1,8 +1,8 @@
package Importer;
-use strict qw/vars subs/; # Not refs!
+use strict; no strict 'refs';
use warnings; no warnings 'once';
-our $VERSION = '0.025';
+our $VERSION = '0.026';
my %SIG_TO_SLOT = (
'&' => 'CODE',