summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Perry <matt@mattperry.com>2018-04-05 12:57:18 -0700
committerMatt Perry <matt@mattperry.com>2018-04-05 12:57:18 -0700
commit8e8fdcf45c86b56813d646a49484badfe595ad60 (patch)
treed92156f1805c9e65a88ba4dec8c99020a68699a6
parent41a0955885d274d3c76107672feb72c32f7584ff (diff)
Remove need for jvm.def on Cygwin
-rw-r--r--Java/Makefile.PL9
-rw-r--r--Java/jvm.def4
2 files changed, 5 insertions, 8 deletions
diff --git a/Java/Makefile.PL b/Java/Makefile.PL
index 05fdf72..537f146 100644
--- a/Java/Makefile.PL
+++ b/Java/Makefile.PL
@@ -113,10 +113,11 @@ if ($build_jni){
# Cygwin: create gcc-compatible library wrapper for jvm.dll
if ($^O eq 'cygwin') {
- my $dll = File::Spec->catfile(Cwd::cwd, 'libjvm.dll.a') ;
- print "Creating '$dll' for cygwin.\n\n" ;
- system("/usr/bin/dlltool --input-def jvm.def --kill-at --dllname jvm.dll --output-lib '$dll'")
- and print "Error attempting to create '$dll'\n" ;
+ my $lib = File::Spec->catfile(Cwd::cwd, 'libjvm.dll.a') ;
+ my $dll = File::Spec->catfile($files->{$jvm_so}->{selected}, 'jvm.dll') ;
+ print "Creating '$lib' for cygwin.\n\n" ;
+ system("/usr/bin/dlltool --kill-at --dllname jvm.dll --output-lib '$lib' '$dll'")
+ and print "Error attempting to create '$lib'\n" ;
}
print "Building with:\n" ;
diff --git a/Java/jvm.def b/Java/jvm.def
deleted file mode 100644
index bdab35d..0000000
--- a/Java/jvm.def
+++ /dev/null
@@ -1,4 +0,0 @@
-EXPORTS
-JNI_CreateJavaVM@12
-JNI_GetDefaultJavaVMInitArgs@4
-JNI_GetCreatedJavaVMs@12