summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMiguel Landaeta <miguel@miguel.cc>2010-08-19 20:32:40 -0430
committerMiguel Landaeta <miguel@miguel.cc>2010-08-19 20:32:40 -0430
commita5dd23a0d24f4a772fa31cc73944f5031451a24c (patch)
tree3c4bac4e862852c0de180209693554f1916d9309 /debian
parentbba4c82c66206b947df4d4c37d4e8106d6a6dafa (diff)
initial debianization
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/clean1
-rw-r--r--debian/compat1
-rw-r--r--debian/control19
-rw-r--r--debian/copyright32
-rw-r--r--debian/javadoc1
-rw-r--r--debian/jlibs1
-rw-r--r--debian/orig-tar.excludes1
-rwxr-xr-xdebian/orig-tar.sh16
-rwxr-xr-xdebian/rules13
-rw-r--r--debian/source/format1
11 files changed, 91 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..08f3f17
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+libjsr305-java (0.1~+svn49-1) UNRELEASED; urgency=low
+
+ * Initial release. (Closes: #552387).
+
+ -- Miguel Landaeta <miguel@miguel.cc> Thu, 19 Aug 2010 20:49:43 -0430
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..a54f913
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+jsr305.jar
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..b6ee831
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,19 @@
+Source: libjsr305-java
+Section: java
+Priority: optional
+Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
+Uploaders: Michael Koch <konqueror@gmx.de>, Miguel Landaeta <miguel@miguel.cc>
+Build-Depends: debhelper (>= 7.0.50~), default-jdk, javahelper
+Standards-Version: 3.9.1
+Homepage: http://code.google.com/p/jsr-305/
+Vcs-Git: git://git.debian.org/pkg-java/libjsr305-java.git
+Vcs-Browser: http://git.debian.org/?p=pkg-java/libjsr305-java.git
+
+Package: libjsr305-java
+Architecture: all
+Depends: ${misc:Depends}
+Description: Java library that provides annotations for software defect detection
+ This library provides the implementation of Java Specification Request 305.
+ JSR-305 specifies annotations for software defect detection. These
+ annotations can used to automatically check that methods are working as
+ expected.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..25759bb
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,32 @@
+The sources where downloaded from http://jsr-305.googlecode.com/svn/trunk/.
+
+Files: *
+Copyright: © 2007-2009, JSR305 expert group
+License: BSD
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions are met:
+
+ * Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+ * Neither the name of the JSR305 expert group nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+ AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
+ THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+ LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ POSSIBILITY OF SUCH DAMAGE.
+
+Files: debian/*
+Copyright: © 2010 Miguel Landaeta <miguel@miguel.cc>
+License: Public Domain
diff --git a/debian/javadoc b/debian/javadoc
new file mode 100644
index 0000000..a6861e4
--- /dev/null
+++ b/debian/javadoc
@@ -0,0 +1 @@
+internal usr/share/doc/libjsr305-java/api
diff --git a/debian/jlibs b/debian/jlibs
new file mode 100644
index 0000000..a54f913
--- /dev/null
+++ b/debian/jlibs
@@ -0,0 +1 @@
+jsr305.jar
diff --git a/debian/orig-tar.excludes b/debian/orig-tar.excludes
new file mode 100644
index 0000000..d51eaf6
--- /dev/null
+++ b/debian/orig-tar.excludes
@@ -0,0 +1 @@
+libjsr305-java-*/javadoc
diff --git a/debian/orig-tar.sh b/debian/orig-tar.sh
new file mode 100755
index 0000000..423c334
--- /dev/null
+++ b/debian/orig-tar.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+set -e
+
+package="`dpkg-parsechangelog | sed -n 's/^Source: //p'`"
+version="`dpkg-parsechangelog | sed -n 's/^Version: //p' | sed 's/-.*$//'`"
+REPO="http://jsr-305.googlecode.com/svn/trunk"
+rev="`echo $version | sed 's/^.*+svn\(.*\)/\1/'`"
+TAR="${package}_${version}.orig.tar.gz"
+DIR="${package}-${version}.orig"
+
+svn export -r $rev ${REPO} ${DIR}
+GZIP=--best tar --numeric --group 0 --owner 0 -cvzf ${TAR} \
+ --exclude=javadoc ${DIR}
+
+rm -rf ${DIR}
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..3c3fc02
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+export JAVA_HOME=/usr/lib/jvm/default-java
+
+%:
+ dh --with javahelper $@
+
+override_jh_build:
+ jh_build jsr305.jar ri/src
+
+get-orig-source:
+ cd $(dir $(firstword $(MAKEFILE_LIST)))../ && \
+ ./debian/orig-tar.sh
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)