summaryrefslogtreecommitdiff
path: root/rules
diff options
context:
space:
mode:
Diffstat (limited to 'rules')
-rwxr-xr-xrules29
1 files changed, 29 insertions, 0 deletions
diff --git a/rules b/rules
new file mode 100755
index 0000000..a650229
--- /dev/null
+++ b/rules
@@ -0,0 +1,29 @@
+#!/usr/bin/make -f
+# -*- mode: makefile; coding: utf-8 -*-
+# © 2013-2014, 2016-2017 Jonas Smedegaard <dr@jones.dk>
+# Description: Main Debian packaging script for lexical::underscore
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+include /usr/share/cdbs/1/rules/utils.mk
+include /usr/share/cdbs/1/class/perl-makemaker.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+pkg = $(DEB_SOURCE_PACKAGE)
+
+# Needed by upstream build process and (always) at runtime
+deps = libpadwalker-perl
+
+CDBS_BUILD_DEPENDS +=, $(deps)
+CDBS_DEPENDS_$(pkg) = $(deps)