summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2020-07-25 17:53:29 +0200
committergregor herrmann <gregoa@debian.org>2020-07-25 17:53:29 +0200
commitc546a56280975abae95f34d0d6890b13e8e2ae0d (patch)
treec2653aaf6dadcfb327bda136c174a0366863f8b3
parent3416dfd27319d9c0de01f516961eae932d9f850a (diff)
parent5b4c4e1af8d1ee922b648e5e439beeff98ed351d (diff)
Update upstream source from tag 'upstream/3.005'
Update to upstream version '3.005' with Debian dir 03e9d6ed4628715268552adc3147d768e17d34c9
-rw-r--r--ChangeLog6
-rw-r--r--META.json2
-rw-r--r--META.yml2
-rw-r--r--Makefile.PL2
-rw-r--r--README.md3
-rw-r--r--lib/Mail/Transport.pm4
-rw-r--r--lib/Mail/Transport.pod6
-rw-r--r--lib/Mail/Transport/Exim.pm4
-rw-r--r--lib/Mail/Transport/Exim.pod6
-rw-r--r--lib/Mail/Transport/Mailx.pm4
-rw-r--r--lib/Mail/Transport/Mailx.pod6
-rw-r--r--lib/Mail/Transport/Qmail.pm4
-rw-r--r--lib/Mail/Transport/Qmail.pod6
-rw-r--r--lib/Mail/Transport/Receive.pm4
-rw-r--r--lib/Mail/Transport/Receive.pod6
-rw-r--r--lib/Mail/Transport/SMTP.pm23
-rw-r--r--lib/Mail/Transport/SMTP.pod6
-rw-r--r--lib/Mail/Transport/Send.pm4
-rw-r--r--lib/Mail/Transport/Send.pod6
-rw-r--r--lib/Mail/Transport/Sendmail.pm4
-rw-r--r--lib/Mail/Transport/Sendmail.pod13
21 files changed, 63 insertions, 58 deletions
diff --git a/ChangeLog b/ChangeLog
index 0531c29..3268fcf 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -4,6 +4,12 @@
All changes are made by Mark Overmeer <markov@cpan.org> unless
explicitly stated differently.
+version 3.005: Wed 22 Jul 10:40:05 CEST 2020
+
+ Improvements:
+ - warn to use ::SMTP, not ::SendMail on bulk messages.
+ - much lower elapse time on ::SMTP (local?) delivery.
+
version 3.004: Fri 3 May 09:29:07 CEST 2019
Improvements:
diff --git a/META.json b/META.json
index e603cad..ae58dab 100644
--- a/META.json
+++ b/META.json
@@ -54,6 +54,6 @@
"web" : "https://github.com/markov2/perl5-Mail-Transport"
}
},
- "version" : "3.004",
+ "version" : "3.005",
"x_serialization_backend" : "JSON::PP version 2.94"
}
diff --git a/META.yml b/META.yml
index d1d8353..9fdea54 100644
--- a/META.yml
+++ b/META.yml
@@ -29,5 +29,5 @@ resources:
homepage: http://perl.overmeer.net/CPAN/
license: http://dev.perl.org/licenses/
repository: https://github.com/markov2/perl5-Mail-Transport.git
-version: '3.004'
+version: '3.005'
x_serialization_backend: 'CPAN::Meta::YAML version 0.011'
diff --git a/Makefile.PL b/Makefile.PL
index 1b75e95..c02b93f 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -4,7 +4,7 @@ require 5.010;
use IO::Handle;
-my $VERSION = '3.004';
+my $VERSION = '3.005';
my %prereq =
( Carp => 0
diff --git a/README.md b/README.md
index b161f50..25d3a21 100644
--- a/README.md
+++ b/README.md
@@ -3,8 +3,7 @@
* My extended documentation: <http://perl.overmeer.net/CPAN/>
* Development via GitHub: <https://github.com/markov2/perl5-Mail-Transport>
* Download from CPAN: <ftp://ftp.cpan.org/pub/CPAN/authors/id/M/MA/MARKOV/>
- * Indexed from CPAN: <http://search.cpan.org/~markov/Mail-Transport/>
- and <https://metacpan.org/release/Mail-Transport>
+ * Indexed from CPAN: <https://metacpan.org/release/Mail-Transport>
Until release 3.0, this module was an integral part of the Mail-Box
distribution. This distribution is dedicate to sending email messages
diff --git a/lib/Mail/Transport.pm b/lib/Mail/Transport.pm
index 3aca557..d01594e 100644
--- a/lib/Mail/Transport.pm
+++ b/lib/Mail/Transport.pm
@@ -1,4 +1,4 @@
-# Copyrights 2001-2019 by [Mark Overmeer].
+# Copyrights 2001-2020 by [Mark Overmeer].
# For other contributors see ChangeLog.
# See the manual pages for details on the licensing terms.
# Pod stripped from pm file by OODoc 2.02.
@@ -8,7 +8,7 @@
package Mail::Transport;
use vars '$VERSION';
-$VERSION = '3.004';
+$VERSION = '3.005';
use base 'Mail::Reporter';
diff --git a/lib/Mail/Transport.pod b/lib/Mail/Transport.pod
index f8a0386..5facca6 100644
--- a/lib/Mail/Transport.pod
+++ b/lib/Mail/Transport.pod
@@ -259,12 +259,12 @@ of the package.
=head1 SEE ALSO
-This module is part of Mail-Transport distribution version 3.004,
-built on May 03, 2019. Website: F<http://perl.overmeer.net/CPAN/>
+This module is part of Mail-Transport distribution version 3.005,
+built on July 22, 2020. Website: F<http://perl.overmeer.net/CPAN/>
=head1 LICENSE
-Copyrights 2001-2019 by [Mark Overmeer]. For other contributors see ChangeLog.
+Copyrights 2001-2020 by [Mark Overmeer]. For other contributors see ChangeLog.
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.
diff --git a/lib/Mail/Transport/Exim.pm b/lib/Mail/Transport/Exim.pm
index 5930c26..97cc058 100644
--- a/lib/Mail/Transport/Exim.pm
+++ b/lib/Mail/Transport/Exim.pm
@@ -1,4 +1,4 @@
-# Copyrights 2001-2019 by [Mark Overmeer].
+# Copyrights 2001-2020 by [Mark Overmeer].
# For other contributors see ChangeLog.
# See the manual pages for details on the licensing terms.
# Pod stripped from pm file by OODoc 2.02.
@@ -8,7 +8,7 @@
package Mail::Transport::Exim;
use vars '$VERSION';
-$VERSION = '3.004';
+$VERSION = '3.005';
use base 'Mail::Transport::Send';
diff --git a/lib/Mail/Transport/Exim.pod b/lib/Mail/Transport/Exim.pod
index e6af4ba..c2e3097 100644
--- a/lib/Mail/Transport/Exim.pod
+++ b/lib/Mail/Transport/Exim.pod
@@ -240,12 +240,12 @@ found in the message itself about the destination.
=head1 SEE ALSO
-This module is part of Mail-Transport distribution version 3.004,
-built on May 03, 2019. Website: F<http://perl.overmeer.net/CPAN/>
+This module is part of Mail-Transport distribution version 3.005,
+built on July 22, 2020. Website: F<http://perl.overmeer.net/CPAN/>
=head1 LICENSE
-Copyrights 2001-2019 by [Mark Overmeer]. For other contributors see ChangeLog.
+Copyrights 2001-2020 by [Mark Overmeer]. For other contributors see ChangeLog.
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.
diff --git a/lib/Mail/Transport/Mailx.pm b/lib/Mail/Transport/Mailx.pm
index 3055b66..aeed051 100644
--- a/lib/Mail/Transport/Mailx.pm
+++ b/lib/Mail/Transport/Mailx.pm
@@ -1,4 +1,4 @@
-# Copyrights 2001-2019 by [Mark Overmeer].
+# Copyrights 2001-2020 by [Mark Overmeer].
# For other contributors see ChangeLog.
# See the manual pages for details on the licensing terms.
# Pod stripped from pm file by OODoc 2.02.
@@ -8,7 +8,7 @@
package Mail::Transport::Mailx;
use vars '$VERSION';
-$VERSION = '3.004';
+$VERSION = '3.005';
use base 'Mail::Transport::Send';
diff --git a/lib/Mail/Transport/Mailx.pod b/lib/Mail/Transport/Mailx.pod
index dda2b01..8670794 100644
--- a/lib/Mail/Transport/Mailx.pod
+++ b/lib/Mail/Transport/Mailx.pod
@@ -259,12 +259,12 @@ accepting messages, but did not succeed sending it.
=head1 SEE ALSO
-This module is part of Mail-Transport distribution version 3.004,
-built on May 03, 2019. Website: F<http://perl.overmeer.net/CPAN/>
+This module is part of Mail-Transport distribution version 3.005,
+built on July 22, 2020. Website: F<http://perl.overmeer.net/CPAN/>
=head1 LICENSE
-Copyrights 2001-2019 by [Mark Overmeer]. For other contributors see ChangeLog.
+Copyrights 2001-2020 by [Mark Overmeer]. For other contributors see ChangeLog.
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.
diff --git a/lib/Mail/Transport/Qmail.pm b/lib/Mail/Transport/Qmail.pm
index 44ac710..25c7c4a 100644
--- a/lib/Mail/Transport/Qmail.pm
+++ b/lib/Mail/Transport/Qmail.pm
@@ -1,4 +1,4 @@
-# Copyrights 2001-2019 by [Mark Overmeer].
+# Copyrights 2001-2020 by [Mark Overmeer].
# For other contributors see ChangeLog.
# See the manual pages for details on the licensing terms.
# Pod stripped from pm file by OODoc 2.02.
@@ -8,7 +8,7 @@
package Mail::Transport::Qmail;
use vars '$VERSION';
-$VERSION = '3.004';
+$VERSION = '3.005';
use base 'Mail::Transport::Send';
diff --git a/lib/Mail/Transport/Qmail.pod b/lib/Mail/Transport/Qmail.pod
index caf44a0..06dc891 100644
--- a/lib/Mail/Transport/Qmail.pod
+++ b/lib/Mail/Transport/Qmail.pod
@@ -236,12 +236,12 @@ found in the message itself about the destination.
=head1 SEE ALSO
-This module is part of Mail-Transport distribution version 3.004,
-built on May 03, 2019. Website: F<http://perl.overmeer.net/CPAN/>
+This module is part of Mail-Transport distribution version 3.005,
+built on July 22, 2020. Website: F<http://perl.overmeer.net/CPAN/>
=head1 LICENSE
-Copyrights 2001-2019 by [Mark Overmeer]. For other contributors see ChangeLog.
+Copyrights 2001-2020 by [Mark Overmeer]. For other contributors see ChangeLog.
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.
diff --git a/lib/Mail/Transport/Receive.pm b/lib/Mail/Transport/Receive.pm
index cfa8410..c1422f6 100644
--- a/lib/Mail/Transport/Receive.pm
+++ b/lib/Mail/Transport/Receive.pm
@@ -1,4 +1,4 @@
-# Copyrights 2001-2019 by [Mark Overmeer].
+# Copyrights 2001-2020 by [Mark Overmeer].
# For other contributors see ChangeLog.
# See the manual pages for details on the licensing terms.
# Pod stripped from pm file by OODoc 2.02.
@@ -8,7 +8,7 @@
package Mail::Transport::Receive;
use vars '$VERSION';
-$VERSION = '3.004';
+$VERSION = '3.005';
use base 'Mail::Transport';
diff --git a/lib/Mail/Transport/Receive.pod b/lib/Mail/Transport/Receive.pod
index 05e8685..350c7b3 100644
--- a/lib/Mail/Transport/Receive.pod
+++ b/lib/Mail/Transport/Receive.pod
@@ -187,12 +187,12 @@ of the package.
=head1 SEE ALSO
-This module is part of Mail-Transport distribution version 3.004,
-built on May 03, 2019. Website: F<http://perl.overmeer.net/CPAN/>
+This module is part of Mail-Transport distribution version 3.005,
+built on July 22, 2020. Website: F<http://perl.overmeer.net/CPAN/>
=head1 LICENSE
-Copyrights 2001-2019 by [Mark Overmeer]. For other contributors see ChangeLog.
+Copyrights 2001-2020 by [Mark Overmeer]. For other contributors see ChangeLog.
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.
diff --git a/lib/Mail/Transport/SMTP.pm b/lib/Mail/Transport/SMTP.pm
index 46ffe26..aa53667 100644
--- a/lib/Mail/Transport/SMTP.pm
+++ b/lib/Mail/Transport/SMTP.pm
@@ -1,4 +1,4 @@
-# Copyrights 2001-2019 by [Mark Overmeer].
+# Copyrights 2001-2020 by [Mark Overmeer].
# For other contributors see ChangeLog.
# See the manual pages for details on the licensing terms.
# Pod stripped from pm file by OODoc 2.02.
@@ -8,7 +8,7 @@
package Mail::Transport::SMTP;
use vars '$VERSION';
-$VERSION = '3.004';
+$VERSION = '3.005';
use base 'Mail::Transport::Send';
@@ -99,17 +99,11 @@ sub trySend($@)
return (0, $server->code, $server->message,"To $_",$server->quit);
}
- $server->data;
- $server->datasend($_) for @headers;
my $bodydata = $message->body->file;
- if(ref $bodydata eq 'GLOB') {
- $server->datasend($_) while <$bodydata>;
- }
- else {
- while(my $l = $bodydata->getline) { $server->datasend($l) }
- }
-
+ $server->data;
+ $server->datasend(\@headers);
+ $server->datasend( [ ref $bodydata eq 'GLOB' ? <$bodydata> : $bodydata->getlines ] );
$server->dataend
or return (0, $server->code, $server->message,'DATA',$server->quit);
@@ -136,12 +130,11 @@ sub trySend($@)
return 0;
}
- $server->data;
- $server->datasend($_) for @headers;
my $bodydata = $message->body->file;
- if(ref $bodydata eq 'GLOB') { $server->datasend($_) while <$bodydata> }
- else { while(my $l = $bodydata->getline) { $server->datasend($l) } }
+ $server->data;
+ $server->datasend(\@headers);
+ $server->datasend( [ ref $bodydata eq 'GLOB' ? <$bodydata> : $bodydata->getlines ] );
$server->quit, return 0
unless $server->dataend;
diff --git a/lib/Mail/Transport/SMTP.pod b/lib/Mail/Transport/SMTP.pod
index 662fbeb..573e2d0 100644
--- a/lib/Mail/Transport/SMTP.pod
+++ b/lib/Mail/Transport/SMTP.pod
@@ -332,12 +332,12 @@ found in the message itself about the destination.
=head1 SEE ALSO
-This module is part of Mail-Transport distribution version 3.004,
-built on May 03, 2019. Website: F<http://perl.overmeer.net/CPAN/>
+This module is part of Mail-Transport distribution version 3.005,
+built on July 22, 2020. Website: F<http://perl.overmeer.net/CPAN/>
=head1 LICENSE
-Copyrights 2001-2019 by [Mark Overmeer]. For other contributors see ChangeLog.
+Copyrights 2001-2020 by [Mark Overmeer]. For other contributors see ChangeLog.
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.
diff --git a/lib/Mail/Transport/Send.pm b/lib/Mail/Transport/Send.pm
index 2464dc3..a1b3148 100644
--- a/lib/Mail/Transport/Send.pm
+++ b/lib/Mail/Transport/Send.pm
@@ -1,4 +1,4 @@
-# Copyrights 2001-2019 by [Mark Overmeer].
+# Copyrights 2001-2020 by [Mark Overmeer].
# For other contributors see ChangeLog.
# See the manual pages for details on the licensing terms.
# Pod stripped from pm file by OODoc 2.02.
@@ -8,7 +8,7 @@
package Mail::Transport::Send;
use vars '$VERSION';
-$VERSION = '3.004';
+$VERSION = '3.005';
use base 'Mail::Transport';
diff --git a/lib/Mail/Transport/Send.pod b/lib/Mail/Transport/Send.pod
index 764dd99..d6493ee 100644
--- a/lib/Mail/Transport/Send.pod
+++ b/lib/Mail/Transport/Send.pod
@@ -331,12 +331,12 @@ but only receive message.
=head1 SEE ALSO
-This module is part of Mail-Transport distribution version 3.004,
-built on May 03, 2019. Website: F<http://perl.overmeer.net/CPAN/>
+This module is part of Mail-Transport distribution version 3.005,
+built on July 22, 2020. Website: F<http://perl.overmeer.net/CPAN/>
=head1 LICENSE
-Copyrights 2001-2019 by [Mark Overmeer]. For other contributors see ChangeLog.
+Copyrights 2001-2020 by [Mark Overmeer]. For other contributors see ChangeLog.
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.
diff --git a/lib/Mail/Transport/Sendmail.pm b/lib/Mail/Transport/Sendmail.pm
index 9e6f428..e6827bb 100644
--- a/lib/Mail/Transport/Sendmail.pm
+++ b/lib/Mail/Transport/Sendmail.pm
@@ -1,4 +1,4 @@
-# Copyrights 2001-2019 by [Mark Overmeer].
+# Copyrights 2001-2020 by [Mark Overmeer].
# For other contributors see ChangeLog.
# See the manual pages for details on the licensing terms.
# Pod stripped from pm file by OODoc 2.02.
@@ -8,7 +8,7 @@
package Mail::Transport::Sendmail;
use vars '$VERSION';
-$VERSION = '3.004';
+$VERSION = '3.005';
use base 'Mail::Transport::Send';
diff --git a/lib/Mail/Transport/Sendmail.pod b/lib/Mail/Transport/Sendmail.pod
index cc9611c..33ff44f 100644
--- a/lib/Mail/Transport/Sendmail.pod
+++ b/lib/Mail/Transport/Sendmail.pod
@@ -26,6 +26,13 @@ Some people use Postfix as MTA. Postfix can be installed as replacement
for Sendmail: is provides a program with the same name and options. So,
this module supports postfix as well.
+B<WARNING:> When you do bulk email sending with local delivery via
+Postfix, you can probably better use the SMTP backend to connect
+to postfix. The C<sendmail> command delivers to C<maildrop>. From
+C<maildrop>, the C<pickupd> will only sequentially insert messages
+into C<cleanup>. That process can take considerable elapse time.
+Directly inserting via C<smtpd> will parallellize the cleanup process.
+
Extends L<"DESCRIPTION" in Mail::Transport::Send|Mail::Transport::Send/"DESCRIPTION">.
=head1 METHODS
@@ -257,12 +264,12 @@ found in the message itself about the destination.
=head1 SEE ALSO
-This module is part of Mail-Transport distribution version 3.004,
-built on May 03, 2019. Website: F<http://perl.overmeer.net/CPAN/>
+This module is part of Mail-Transport distribution version 3.005,
+built on July 22, 2020. Website: F<http://perl.overmeer.net/CPAN/>
=head1 LICENSE
-Copyrights 2001-2019 by [Mark Overmeer]. For other contributors see ChangeLog.
+Copyrights 2001-2020 by [Mark Overmeer]. For other contributors see ChangeLog.
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.