summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog7
-rw-r--r--META.yml2
-rw-r--r--MYMETA.json2
-rw-r--r--MYMETA.yml2
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rw-r--r--lib/MIME/Body.pm2
-rw-r--r--lib/MIME/Decoder.pm2
-rw-r--r--lib/MIME/Decoder/Base64.pm2
-rw-r--r--lib/MIME/Decoder/BinHex.pm2
-rw-r--r--lib/MIME/Decoder/Binary.pm2
-rw-r--r--lib/MIME/Decoder/Gzip64.pm2
-rw-r--r--lib/MIME/Decoder/NBit.pm2
-rw-r--r--lib/MIME/Decoder/QuotedPrint.pm2
-rw-r--r--lib/MIME/Decoder/UU.pm2
-rw-r--r--lib/MIME/Entity.pm2
-rw-r--r--lib/MIME/Field/ConTraEnc.pm2
-rw-r--r--lib/MIME/Field/ContDisp.pm2
-rw-r--r--lib/MIME/Field/ContType.pm2
-rw-r--r--lib/MIME/Field/ParamVal.pm2
-rw-r--r--lib/MIME/Head.pm2
-rw-r--r--lib/MIME/Parser.pm2
-rw-r--r--lib/MIME/Tools.pm2
-rw-r--r--lib/MIME/Words.pm2
-rw-r--r--t/ticket-119568.t8
25 files changed, 40 insertions, 26 deletions
diff --git a/ChangeLog b/ChangeLog
index 3ee1ca7..1864e86 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+5.515 2024-04-24 Dianne Skoll <dianne@skoll.ca>
+
+ * VERSION 5.514 RELEASED
+
+ * Fix the "version" setting in META.yml. There are no other changes
+ since 5.514.
+
5.514 2024-02-06 Dianne Skoll <dianne@skoll.ca>
* VERSION 5.514 RELEASED
diff --git a/META.yml b/META.yml
index 8d5c411..96884de 100644
--- a/META.yml
+++ b/META.yml
@@ -37,4 +37,4 @@ requires:
perl: 5.8.0
resources:
license: http://dev.perl.org/licenses/
-version: 5.503
+version: 5.515
diff --git a/MYMETA.json b/MYMETA.json
index 389da38..6682931 100644
--- a/MYMETA.json
+++ b/MYMETA.json
@@ -58,7 +58,7 @@
"http://dev.perl.org/licenses/"
]
},
- "version" : "5.503",
+ "version" : "5.515",
"x_module_name" : "MIME::Tools",
"x_serialization_backend" : "JSON::PP version 4.07"
}
diff --git a/MYMETA.yml b/MYMETA.yml
index 6298f73..2f22997 100644
--- a/MYMETA.yml
+++ b/MYMETA.yml
@@ -36,6 +36,6 @@ requires:
perl: '5.008'
resources:
license: http://dev.perl.org/licenses/
-version: '5.503'
+version: '5.515'
x_module_name: MIME::Tools
x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff --git a/debian/changelog b/debian/changelog
index db7b3ca..4f3de47 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+libmime-tools-perl (5.515-1) unstable; urgency=medium
+
+ * Import upstream version 5.515.
+ * Declare compliance with Debian Policy 4.7.0.
+
+ -- gregor herrmann <gregoa@debian.org> Sat, 27 Apr 2024 20:59:25 +0200
+
libmime-tools-perl (5.514-1) unstable; urgency=medium
* Import upstream version 5.514.
diff --git a/debian/control b/debian/control
index 91fd0b5..9280bca 100644
--- a/debian/control
+++ b/debian/control
@@ -15,7 +15,7 @@ Build-Depends-Indep: libconvert-binhex-perl <!nocheck>,
libtest-pod-perl <!nocheck>,
netbase <!nocheck>,
perl
-Standards-Version: 4.6.2
+Standards-Version: 4.7.0
Vcs-Browser: https://salsa.debian.org/perl-team/modules/packages/libmime-tools-perl
Vcs-Git: https://salsa.debian.org/perl-team/modules/packages/libmime-tools-perl.git
Homepage: https://metacpan.org/release/MIME-tools
diff --git a/lib/MIME/Body.pm b/lib/MIME/Body.pm
index 7d4bf68..8c81567 100644
--- a/lib/MIME/Body.pm
+++ b/lib/MIME/Body.pm
@@ -141,7 +141,7 @@ use Carp;
use IO::File;
### The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
#------------------------------
diff --git a/lib/MIME/Decoder.pm b/lib/MIME/Decoder.pm
index 4c032ef..e54986a 100644
--- a/lib/MIME/Decoder.pm
+++ b/lib/MIME/Decoder.pm
@@ -126,7 +126,7 @@ use Carp;
);
### The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
### Me:
my $ME = 'MIME::Decoder';
diff --git a/lib/MIME/Decoder/Base64.pm b/lib/MIME/Decoder/Base64.pm
index 893a569..51100ea 100644
--- a/lib/MIME/Decoder/Base64.pm
+++ b/lib/MIME/Decoder/Base64.pm
@@ -57,7 +57,7 @@ use MIME::Tools qw(debug);
@ISA = qw(MIME::Decoder);
### The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
### How many bytes to encode at a time (must be a multiple of 3)
my $EncodeChunkLength = 120 * 57;
diff --git a/lib/MIME/Decoder/BinHex.pm b/lib/MIME/Decoder/BinHex.pm
index 4fdaad3..22d366f 100644
--- a/lib/MIME/Decoder/BinHex.pm
+++ b/lib/MIME/Decoder/BinHex.pm
@@ -47,7 +47,7 @@ use Convert::BinHex;
@ISA = qw(MIME::Decoder);
# The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
#------------------------------
diff --git a/lib/MIME/Decoder/Binary.pm b/lib/MIME/Decoder/Binary.pm
index 93e7e3b..8553cfb 100644
--- a/lib/MIME/Decoder/Binary.pm
+++ b/lib/MIME/Decoder/Binary.pm
@@ -47,7 +47,7 @@ use vars qw(@ISA $VERSION);
@ISA = qw(MIME::Decoder);
### The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
### Buffer length:
my $BUFLEN = 8192;
diff --git a/lib/MIME/Decoder/Gzip64.pm b/lib/MIME/Decoder/Gzip64.pm
index 66db1a4..4aee652 100644
--- a/lib/MIME/Decoder/Gzip64.pm
+++ b/lib/MIME/Decoder/Gzip64.pm
@@ -61,7 +61,7 @@ use MIME::Tools qw(tmpopen whine);
@ISA = qw(MIME::Decoder::Base64);
# The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
# How to compress stdin to stdout:
$GZIP = "gzip -c";
diff --git a/lib/MIME/Decoder/NBit.pm b/lib/MIME/Decoder/NBit.pm
index 77d9160..3f2f246 100644
--- a/lib/MIME/Decoder/NBit.pm
+++ b/lib/MIME/Decoder/NBit.pm
@@ -98,7 +98,7 @@ use MIME::Tools qw(:msgs);
@ISA = qw(MIME::Decoder);
### The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
### How many bytes to decode at a time?
my $DecodeChunkLength = 8 * 1024;
diff --git a/lib/MIME/Decoder/QuotedPrint.pm b/lib/MIME/Decoder/QuotedPrint.pm
index 809b1ea..4403488 100644
--- a/lib/MIME/Decoder/QuotedPrint.pm
+++ b/lib/MIME/Decoder/QuotedPrint.pm
@@ -58,7 +58,7 @@ use MIME::QuotedPrint;
@ISA = qw(MIME::Decoder);
# The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
#------------------------------
# If we have MIME::QuotedPrint 3.03 or later, use the three-argument
diff --git a/lib/MIME/Decoder/UU.pm b/lib/MIME/Decoder/UU.pm
index b7cf449..afaa49f 100644
--- a/lib/MIME/Decoder/UU.pm
+++ b/lib/MIME/Decoder/UU.pm
@@ -48,7 +48,7 @@ use MIME::Tools qw(whine);
@ISA = qw(MIME::Decoder);
# The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
#------------------------------
diff --git a/lib/MIME/Entity.pm b/lib/MIME/Entity.pm
index b77f4af..83d8577 100644
--- a/lib/MIME/Entity.pm
+++ b/lib/MIME/Entity.pm
@@ -255,7 +255,7 @@ use MIME::Decoder;
#------------------------------
### The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
### Boundary counter:
my $BCount = 0;
diff --git a/lib/MIME/Field/ConTraEnc.pm b/lib/MIME/Field/ConTraEnc.pm
index a24abd4..49deff0 100644
--- a/lib/MIME/Field/ConTraEnc.pm
+++ b/lib/MIME/Field/ConTraEnc.pm
@@ -47,7 +47,7 @@ use vars qw($VERSION @ISA);
@ISA = qw(MIME::Field::ParamVal);
# The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
# Install it:
bless([])->register('Content-transfer-encoding');
diff --git a/lib/MIME/Field/ContDisp.pm b/lib/MIME/Field/ContDisp.pm
index bec394f..e358641 100644
--- a/lib/MIME/Field/ContDisp.pm
+++ b/lib/MIME/Field/ContDisp.pm
@@ -48,7 +48,7 @@ use vars qw($VERSION @ISA);
@ISA = qw(MIME::Field::ParamVal);
# The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
# Install it:
bless([])->register('Content-disposition');
diff --git a/lib/MIME/Field/ContType.pm b/lib/MIME/Field/ContType.pm
index 4a93886..871c33a 100644
--- a/lib/MIME/Field/ContType.pm
+++ b/lib/MIME/Field/ContType.pm
@@ -63,7 +63,7 @@ use vars qw($VERSION @ISA);
@ISA = qw(MIME::Field::ParamVal);
# The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
# Install it:
bless([])->register('Content-type');
diff --git a/lib/MIME/Field/ParamVal.pm b/lib/MIME/Field/ParamVal.pm
index 0360963..c4080a4 100644
--- a/lib/MIME/Field/ParamVal.pm
+++ b/lib/MIME/Field/ParamVal.pm
@@ -80,7 +80,7 @@ use MIME::Tools qw(:config :msgs);
#------------------------------
# The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
#------------------------------
diff --git a/lib/MIME/Head.pm b/lib/MIME/Head.pm
index 412e55b..ce526a0 100644
--- a/lib/MIME/Head.pm
+++ b/lib/MIME/Head.pm
@@ -159,7 +159,7 @@ my $singleton_parameter_headers =
#------------------------------
### The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
### Sanity (we put this test after our own version, for CPAN::):
use Mail::Header 1.06 ();
diff --git a/lib/MIME/Parser.pm b/lib/MIME/Parser.pm
index 42c1351..63a0934 100644
--- a/lib/MIME/Parser.pm
+++ b/lib/MIME/Parser.pm
@@ -153,7 +153,7 @@ use MIME::Parser::Results;
#------------------------------
### The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
### How to catenate:
$CAT = '/bin/cat';
diff --git a/lib/MIME/Tools.pm b/lib/MIME/Tools.pm
index 79d174b..315d914 100644
--- a/lib/MIME/Tools.pm
+++ b/lib/MIME/Tools.pm
@@ -28,7 +28,7 @@ $ME = "MIME-tools";
Exporter::export_ok_tags('config', 'msgs', 'msgtypes', 'utils');
# The TOOLKIT version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
# Configuration (do NOT alter this directly)...
# All legal CONFIG vars *must* be in here, even if only to be set to undef:
diff --git a/lib/MIME/Words.pm b/lib/MIME/Words.pm
index 22540b1..db87e15 100644
--- a/lib/MIME/Words.pm
+++ b/lib/MIME/Words.pm
@@ -94,7 +94,7 @@ use MIME::QuotedPrint;
#------------------------------
### The package version, both in 1.23 style *and* usable by MakeMaker:
-$VERSION = "5.514";
+$VERSION = "5.515";
### Nonprintables (controls + x7F + 8bit):
my $NONPRINT = "\\x00-\\x1F\\x7F-\\xFF";
diff --git a/t/ticket-119568.t b/t/ticket-119568.t
index d9499d5..4768ab7 100644
--- a/t/ticket-119568.t
+++ b/t/ticket-119568.t
@@ -13,7 +13,7 @@ my $e = MIME::Entity->build(From => 'dianne@skoll.ca',
Data => ["Line 1\n", "Line 2\n"],);
my $str = $e->as_string();
-is ($str, "Content-Type: text/plain\nContent-Disposition: inline\nContent-Transfer-Encoding: binary\nMIME-Version: 1.0\nX-Mailer: MIME-tools 5.514 (Entity 5.514)\nFrom: dianne\@skoll.ca\nTo: dfs2\@roaringpenguin.com\nSubject: End-of-line test\n\nLine 1\nLine 2\n", 'Got expected line endings');
+is ($str, "Content-Type: text/plain\nContent-Disposition: inline\nContent-Transfer-Encoding: binary\nMIME-Version: 1.0\nX-Mailer: MIME-tools 5.515 (Entity 5.515)\nFrom: dianne\@skoll.ca\nTo: dfs2\@roaringpenguin.com\nSubject: End-of-line test\n\nLine 1\nLine 2\n", 'Got expected line endings');
my $delim = "\r\n";
$MIME::Entity::BOUNDARY_DELIMITER = $delim;
@@ -24,7 +24,7 @@ $e = MIME::Entity->build(From => 'dianne@skoll.ca',
$str = $e->as_string();
-is ($str, "Content-Type: text/plain${delim}Content-Disposition: inline${delim}Content-Transfer-Encoding: binary${delim}MIME-Version: 1.0${delim}X-Mailer: MIME-tools 5.514 (Entity 5.514)${delim}From: dianne\@skoll.ca${delim}To: dfs2\@roaringpenguin.com${delim}Subject: End-of-line test${delim}${delim}Line 1${delim}Line 2${delim}", 'Got expected line endings');
+is ($str, "Content-Type: text/plain${delim}Content-Disposition: inline${delim}Content-Transfer-Encoding: binary${delim}MIME-Version: 1.0${delim}X-Mailer: MIME-tools 5.515 (Entity 5.515)${delim}From: dianne\@skoll.ca${delim}To: dfs2\@roaringpenguin.com${delim}Subject: End-of-line test${delim}${delim}Line 1${delim}Line 2${delim}", 'Got expected line endings');
$e->attach(Data => ["More Text$delim"], Type => "text/plain");
@@ -35,7 +35,7 @@ $e = MIME::Entity->build(From => 'dianne@skoll.ca',
$e->attach(Data => ["Text$delim"], Type => "text/plain");
$e->attach(Data => ["More Text$delim"], Type => "text/plain");
$str = $e->as_string();
-is ($str, "Content-Type: multipart/mixed; boundary=\"foo\"${delim}Content-Transfer-Encoding: binary${delim}MIME-Version: 1.0${delim}X-Mailer: MIME-tools 5.514 (Entity 5.514)${delim}From: dianne\@skoll.ca${delim}To: dfs2\@roaringpenguin.com${delim}Subject: End-of-line test${delim}${delim}This is a multi-part message in MIME format...${delim}${delim}--foo${delim}Content-Type: text/plain${delim}Content-Disposition: inline${delim}Content-Transfer-Encoding: binary${delim}${delim}Text${delim}${delim}--foo${delim}Content-Type: text/plain${delim}Content-Disposition: inline${delim}Content-Transfer-Encoding: binary${delim}${delim}More Text${delim}${delim}--foo--${delim}", 'Got expected line endings');
+is ($str, "Content-Type: multipart/mixed; boundary=\"foo\"${delim}Content-Transfer-Encoding: binary${delim}MIME-Version: 1.0${delim}X-Mailer: MIME-tools 5.515 (Entity 5.515)${delim}From: dianne\@skoll.ca${delim}To: dfs2\@roaringpenguin.com${delim}Subject: End-of-line test${delim}${delim}This is a multi-part message in MIME format...${delim}${delim}--foo${delim}Content-Type: text/plain${delim}Content-Disposition: inline${delim}Content-Transfer-Encoding: binary${delim}${delim}Text${delim}${delim}--foo${delim}Content-Type: text/plain${delim}Content-Disposition: inline${delim}Content-Transfer-Encoding: binary${delim}${delim}More Text${delim}${delim}--foo--${delim}", 'Got expected line endings');
$e = MIME::Entity->build(From => 'dianne@skoll.ca',
To => 'dfs2@roaringpenguin.com',
@@ -45,5 +45,5 @@ $e->attach(Data => ["Text\n"], Type => "text/plain", Encoding => 'Base64');
$e->attach(Data => ["More Text\n", 'LongLine' x 120], Type => "text/plain", Encoding => 'Base64');
$str = $e->as_string();
-is ($str, "Content-Type: multipart/mixed; boundary=\"foo\"${delim}Content-Transfer-Encoding: binary${delim}MIME-Version: 1.0${delim}X-Mailer: MIME-tools 5.514 (Entity 5.514)${delim}From: dianne\@skoll.ca${delim}To: dfs2\@roaringpenguin.com${delim}Subject: End-of-line test${delim}${delim}This is a multi-part message in MIME format...${delim}${delim}--foo${delim}Content-Type: text/plain${delim}Content-Disposition: inline${delim}Content-Transfer-Encoding: Base64${delim}${delim}VGV4dAo=${delim}${delim}--foo${delim}Content-Type: text/plain${delim}Content-Disposition: inline${delim}Content-Transfer-Encoding: Base64${delim}${delim}TW9yZSBUZXh0CkxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGlu${delim}ZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5l${delim}TG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVM${delim}b25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxv${delim}bmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9u${delim}Z0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25n${delim}TGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdM${delim}aW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xp${delim}bmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGlu${delim}ZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5l${delim}TG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVM${delim}b25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxv${delim}bmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9u${delim}Z0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25n${delim}TGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdM${delim}aW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xp${delim}bmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGlu${delim}ZQ==${delim}${delim}--foo--${delim}", 'Got expected line endings for Base64 encoding');
+is ($str, "Content-Type: multipart/mixed; boundary=\"foo\"${delim}Content-Transfer-Encoding: binary${delim}MIME-Version: 1.0${delim}X-Mailer: MIME-tools 5.515 (Entity 5.515)${delim}From: dianne\@skoll.ca${delim}To: dfs2\@roaringpenguin.com${delim}Subject: End-of-line test${delim}${delim}This is a multi-part message in MIME format...${delim}${delim}--foo${delim}Content-Type: text/plain${delim}Content-Disposition: inline${delim}Content-Transfer-Encoding: Base64${delim}${delim}VGV4dAo=${delim}${delim}--foo${delim}Content-Type: text/plain${delim}Content-Disposition: inline${delim}Content-Transfer-Encoding: Base64${delim}${delim}TW9yZSBUZXh0CkxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGlu${delim}ZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5l${delim}TG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVM${delim}b25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxv${delim}bmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9u${delim}Z0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25n${delim}TGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdM${delim}aW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xp${delim}bmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGlu${delim}ZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5l${delim}TG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVM${delim}b25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxv${delim}bmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9u${delim}Z0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25n${delim}TGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdM${delim}aW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xp${delim}bmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGluZUxvbmdMaW5lTG9uZ0xpbmVMb25nTGlu${delim}ZQ==${delim}${delim}--foo--${delim}", 'Got expected line endings for Base64 encoding');