summaryrefslogtreecommitdiff
path: root/src/libmowgli/platform/Makefile
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2014-06-17 11:57:32 +0200
committerAndrew Shadura <andrew@shadura.me>2014-06-17 11:57:32 +0200
commitd1e7e16224c881ee3093658fe4cbf14db244cec7 (patch)
tree8850e7a55b4b1589a7a08e2364e9c12dad31962c /src/libmowgli/platform/Makefile
parent246fb6b81eef837f1269073255373bf0a3d5c27a (diff)
Update to the latest upstream snapshot
Diffstat (limited to 'src/libmowgli/platform/Makefile')
-rw-r--r--src/libmowgli/platform/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/libmowgli/platform/Makefile b/src/libmowgli/platform/Makefile
index 6b6d7b9..7d883d4 100644
--- a/src/libmowgli/platform/Makefile
+++ b/src/libmowgli/platform/Makefile
@@ -1,9 +1,17 @@
+include ../../../extra.mk
+
+STATIC_PIC_LIB_NOINST = ${LIBMOWGLI_SHARED_PLATFORM}
+STATIC_LIB_NOINST = ${LIBMOWGLI_STATIC_PLATFORM}
+
SUBDIRS = win32
-INCLUDES = constructor.h machine.h
+SRCS = cacheline.c
+
+INCLUDES = attributes.h cacheline.h constructor.h machine.h
include ../../../buildsys.mk
includesubdir = $(PACKAGE_NAME)/platform
-include ../../../extra.mk
+CPPFLAGS += -I. -I.. -I../../.. -DMOWGLI_CORE
+