summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/001-Disable_Makefile_silent_output.diff14
-rw-r--r--debian/patches/002-Make-Examples-Buildable-standalone.diff302
-rw-r--r--debian/patches/003-Fix-machine.h.diff11
-rw-r--r--debian/patches/004-No-openssl.diff15
-rw-r--r--debian/patches/series4
5 files changed, 0 insertions, 346 deletions
diff --git a/debian/patches/001-Disable_Makefile_silent_output.diff b/debian/patches/001-Disable_Makefile_silent_output.diff
deleted file mode 100644
index 7189358..0000000
--- a/debian/patches/001-Disable_Makefile_silent_output.diff
+++ /dev/null
@@ -1,14 +0,0 @@
-Author: Adam Cécile (Le_Vert) <gandalf@le-vert.net>
-Description: Let's show what happens...
-
---- a/buildsys.mk.in
-+++ b/buildsys.mk.in
-@@ -102,7 +102,7 @@
-
- MO_FILES = ${LOCALES:.po=.mo}
-
--.SILENT:
-+#.SILENT:
- .SUFFIXES:
- .SUFFIXES: .beam .c .c.dep .cc .cc.dep .class .cxx .cxx.dep .d .erl .lib.o .java .mo .m .m.dep .mm .mm.dep .o .plugin.o .po .py .pyc .rc .S .S.dep .xpm
- .PHONY: all subdirs ${SUBDIRS} pre-depend depend install install-extra uninstall uninstall-extra clean distclean locales
diff --git a/debian/patches/002-Make-Examples-Buildable-standalone.diff b/debian/patches/002-Make-Examples-Buildable-standalone.diff
deleted file mode 100644
index 180f9b9..0000000
--- a/debian/patches/002-Make-Examples-Buildable-standalone.diff
+++ /dev/null
@@ -1,302 +0,0 @@
-Author: Adam Cécile (Le_Vert) <gandalf@le-vert.net>
-Description: This patch makes the examples build standalone.
-
---- a/src/examples/formattertest/formattertest.c
-+++ b/src/examples/formattertest/formattertest.c
-@@ -31,7 +31,7 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- int
- main(int argc, char *argv[])
---- a/src/examples/formattertest/Makefile
-+++ b/src/examples/formattertest/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = formattertest${PROG_SUFFIX}
- SRCS = formattertest.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/listsort/listsort.c
-+++ b/src/examples/listsort/listsort.c
-@@ -31,7 +31,7 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- #ifdef _WIN32
- # define strcasecmp _stricmp
---- a/src/examples/listsort/Makefile
-+++ b/src/examples/listsort/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = listsort${PROG_SUFFIX}
- SRCS = listsort.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/randomtest/Makefile
-+++ b/src/examples/randomtest/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = randomtest${PROG_SUFFIX}
- SRCS = randomtest.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/randomtest/randomtest.c
-+++ b/src/examples/randomtest/randomtest.c
-@@ -31,7 +31,7 @@
- * IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- * POSSIBILITY OF SUCH DAMAGE.
- */
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- int
- main(int argc, char *argv[])
---- a/src/examples/async_resolver/async_resolver.c
-+++ b/src/examples/async_resolver/async_resolver.c
-@@ -1,6 +1,6 @@
- /* This code is in the public domain. */
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- typedef struct
- {
---- a/src/examples/async_resolver/Makefile
-+++ b/src/examples/async_resolver/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = async_resolver${PROG_SUFFIX}
- SRCS = async_resolver.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/echoserver/echoserver.c
-+++ b/src/examples/echoserver/echoserver.c
-@@ -21,7 +21,7 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- mowgli_eventloop_t *base_eventloop;
- mowgli_eventloop_pollable_t *listener;
---- a/src/examples/echoserver/Makefile
-+++ b/src/examples/echoserver/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = echoserver${PROG_SUFFIX}
- SRCS = echoserver.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/helpertest/helpertest.c
-+++ b/src/examples/helpertest/helpertest.c
-@@ -21,7 +21,7 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- int helper_count = 0;
-
---- a/src/examples/helpertest/Makefile
-+++ b/src/examples/helpertest/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = helpertest${PROG_SUFFIX}
- SRCS = helpertest.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/libevent-bench/bench.c
-+++ b/src/examples/libevent-bench/bench.c
-@@ -76,7 +76,7 @@
- } \
- } while (0)
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- static int count, writes, fired;
- static mowgli_eventloop_t *base_eventloop;
---- a/src/examples/libevent-bench/Makefile
-+++ b/src/examples/libevent-bench/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = bench${PROG_SUFFIX}
- SRCS = bench.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/linetest/linetest.c
-+++ b/src/examples/linetest/linetest.c
-@@ -22,7 +22,7 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- mowgli_eventloop_t *base_eventloop;
- char buf[512];
---- a/src/examples/linetest/Makefile
-+++ b/src/examples/linetest/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = linetest${PROG_SUFFIX}
- SRCS = linetest.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/memslice-bench/Makefile
-+++ b/src/examples/memslice-bench/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = memslice-bench${PROG_SUFFIX}
- SRCS = memslice-bench.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/memslice-bench/memslice-bench.c
-+++ b/src/examples/memslice-bench/memslice-bench.c
-@@ -30,7 +30,7 @@
- } \
- } while (0)
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- mowgli_allocation_policy_t *memslice;
- mowgli_allocation_policy_t *sysmalloc;
---- a/src/examples/patriciatest2/Makefile
-+++ b/src/examples/patriciatest2/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = patriciatest2${PROG_SUFFIX}
- SRCS = patriciatest2.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/patriciatest2/patriciatest2.c
-+++ b/src/examples/patriciatest2/patriciatest2.c
-@@ -31,7 +31,7 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- #define TESTSIZE 10000
-
---- a/src/examples/patriciatest/Makefile
-+++ b/src/examples/patriciatest/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = patriciatest${PROG_SUFFIX}
- SRCS = patriciatest.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/patriciatest/patriciatest.c
-+++ b/src/examples/patriciatest/patriciatest.c
-@@ -31,7 +31,7 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- int errors = 0;
-
---- a/src/examples/timertest/Makefile
-+++ b/src/examples/timertest/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = timertest${PROG_SUFFIX}
- SRCS = timertest.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/timertest/timertest.c
-+++ b/src/examples/timertest/timertest.c
-@@ -21,7 +21,7 @@
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- mowgli_eventloop_t *eventloop;
-
---- a/src/examples/vio-udplistener/Makefile
-+++ b/src/examples/vio-udplistener/Makefile
-@@ -1,7 +1,7 @@
- PROG_NOINST = vio-udplistener${PROG_SUFFIX}
- SRCS = vio-udplistener.c
-
--include ../../../buildsys.mk
-+include ../buildsys.mk
-
- CPPFLAGS += -I../../libmowgli
- LIBS += -L../../libmowgli -lmowgli-2
---- a/src/examples/vio-udplistener/vio-udplistener.c
-+++ b/src/examples/vio-udplistener/vio-udplistener.c
-@@ -3,7 +3,7 @@
- * This example is public domain.
- */
-
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- #define BUFSIZE 2048
-
---- a/src/examples/Makefile
-+++ b/src/examples/Makefile
-@@ -1,2 +1,2 @@
- SUBDIRS = echoserver vio-udplistener async_resolver formattertest helpertest jsontest libevent-bench linetest listsort memslice-bench patriciatest patriciatest2 randomtest timertest
--include ../../buildsys.mk
-+include buildsys.mk
---- a/src/examples/jsontest/jsontest.c
-+++ b/src/examples/jsontest/jsontest.c
-@@ -1,4 +1,4 @@
--#include <mowgli.h>
-+#include <libmowgli-2/mowgli.h>
-
- void
- out_string(mowgli_json_output_t *out, const char *str, size_t len)
diff --git a/debian/patches/003-Fix-machine.h.diff b/debian/patches/003-Fix-machine.h.diff
deleted file mode 100644
index 4e3ffa4..0000000
--- a/debian/patches/003-Fix-machine.h.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/libmowgli/platform/machine.h
-+++ b/src/libmowgli/platform/machine.h
-@@ -192,7 +192,7 @@
- # endif
- #endif
-
--#if defined __linux || defined __linux__
-+#if defined __linux || defined __linux__ || defined __FreeBSD_kernel__
- # define MOWGLI_OS_LINUX
- # define MOWGLI_OS linux
- # define MOWGLI_OS_THREADS_POSIX
diff --git a/debian/patches/004-No-openssl.diff b/debian/patches/004-No-openssl.diff
deleted file mode 100644
index 1a8cf7d..0000000
--- a/debian/patches/004-No-openssl.diff
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/m4/ax_check_openssl.m4
-+++ b/m4/ax_check_openssl.m4
-@@ -42,9 +42,11 @@
- [root of the OpenSSL directory])],
- [
- case "$withval" in
-- "" | y | ye | yes | n | no)
-+ y | ye | yes)
- AC_MSG_ERROR([Invalid --with-openssl value])
- ;;
-+ "" | n | no) ssldirs=""
-+ ;;
- *) ssldirs="$withval"
- ;;
- esac
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 7b4be3e..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,4 +0,0 @@
-001-Disable_Makefile_silent_output.diff
-002-Make-Examples-Buildable-standalone.diff
-003-Fix-machine.h.diff
-004-No-openssl.diff