summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorKen Dreyer <ktdreyer@ktdreyer.com>2013-05-19 13:34:49 -0600
committerKen Dreyer <ktdreyer@ktdreyer.com>2013-05-19 16:43:54 -0600
commit0cf0d686e2cadf37b4085d0a321fbb72d83dbec3 (patch)
treee954e5e8b9eb5ee69e285a631032a3d4551db29f /Makefile.PL
parentc4dc73f1c6fc0dc3b28fc8c1dd47a2953a95fbd1 (diff)
add more metadata to Makefile.PL
Add the author name, license information, and GitHub URLs to Makefile.pl. ExtUtils::MakeMaker will use CPAN::Meta (if installed) to write the data into special metadata files, and the information and links will show up on CPAN's web interface.
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 693fd4e..6fa46c0 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -6,10 +6,24 @@ my $xt = prompt( "Should I do external tests?\n".
"[y/N]", 'n' );
WriteMakefile(
NAME => 'Net::INET6Glue',
+ AUTHOR => q{Steffen Ullrich <Steffen_Ullrich@genua.de>},
VERSION_FROM => 'lib/Net/INET6Glue.pm',
PREREQ_PM => {
'IO::Socket::INET6' => 2.54,
'Net::FTP' => 2.75,
},
+ ($ExtUtils::MakeMaker::VERSION < 6.3002 ? () : (
+ LICENSE => 'perl',
+ )),
+ ($ExtUtils::MakeMaker::VERSION < 6.46 ? () : (
+ META_MERGE => {
+ resources => {
+ license => 'http://dev.perl.org/licenses/',
+ homepage => 'https://github.com/noxxi/p5-net-inet6glue',
+ bugtracker => 'https://github.com/noxxi/p5-net-inet6glue/issues',
+ Repository => 'https://github.com/noxxi/p5-net-inet6glue',
+ },
+ },
+ )),
$xt =~m{^y}i ? ( test => { TESTS => 't/*.t t/external/*.t' }):(),
);