summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorSteffen Ullrich <Steffen_Ullrich@genua.de>2013-05-30 05:45:33 +0200
committerSteffen Ullrich <Steffen_Ullrich@genua.de>2013-05-30 05:45:33 +0200
commit4ad74db82cb3910f603ac5846ca1ae43e9462b5b (patch)
tree47b94078afecb66ea2d078d2dd2bb7f0fc06d796 /Makefile.PL
parentde3061a0f7c1be410f11dbf36233ef18f72c94c9 (diff)
0.6 - more meta information to Makefile.PL based on patch from ktdreyer
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL49
1 files changed, 24 insertions, 25 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 6fa46c0..79c099a 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,29 +1,28 @@
-use ExtUtils::MakeMaker;
+use ExtUtils::MakeMaker 6.46;
require 5.008;
-my $xt = prompt( "Should I do external tests?\n".
- "These tests will fail if there is no internet connection or if a firewall\n".
- "blocks active or passive IPv6 FTP traffic.\n".
- "[y/N]", 'n' );
+my $xt = prompt(
+ "Should I do external tests?\n".
+ "These tests will fail if there is no internet connection or if a firewall\n".
+ "blocks active or passive IPv6 FTP traffic.\n".
+ "[y/N]",
+ 'n'
+);
WriteMakefile(
- NAME => 'Net::INET6Glue',
- AUTHOR => q{Steffen Ullrich <Steffen_Ullrich@genua.de>},
- VERSION_FROM => 'lib/Net/INET6Glue.pm',
- PREREQ_PM => {
- 'IO::Socket::INET6' => 2.54,
- 'Net::FTP' => 2.75,
+ NAME => 'Net::INET6Glue',
+ AUTHOR => [ "Steffen Ullrich <sullr@cpan.org>" ],
+ LICENSE => 'perl',
+ VERSION_FROM => 'lib/Net/INET6Glue.pm',
+ PREREQ_PM => {
+ 'IO::Socket::INET6' => 2.54,
+ 'Net::FTP' => 2.75,
+ },
+ META_MERGE => {
+ resources => {
+ license => 'http://dev.perl.org/licenses/',
+ homepage => 'https://github.com/noxxi/p5-net-inet6glue',
+ bugtracker => 'https://rt.cpan.org/Dist/Display.html?Queue=Net-INET6Glue',
+ Repository => 'https://github.com/noxxi/p5-net-inet6glue',
},
- ($ExtUtils::MakeMaker::VERSION < 6.3002 ? () : (
- LICENSE => 'perl',
- )),
- ($ExtUtils::MakeMaker::VERSION < 6.46 ? () : (
- META_MERGE => {
- resources => {
- license => 'http://dev.perl.org/licenses/',
- homepage => 'https://github.com/noxxi/p5-net-inet6glue',
- bugtracker => 'https://github.com/noxxi/p5-net-inet6glue/issues',
- Repository => 'https://github.com/noxxi/p5-net-inet6glue',
- },
- },
- )),
- $xt =~m{^y}i ? ( test => { TESTS => 't/*.t t/external/*.t' }):(),
+ },
+ $xt =~m{^y}i ? ( test => { TESTS => 't/*.t t/external/*.t' }):(),
);