summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorMichael Stapelberg <michael@stapelberg.de>2011-08-27 12:05:44 +0200
committerMichael Stapelberg <michael@stapelberg.de>2011-08-27 12:05:44 +0200
commit8bf7ffcc9bd13c080a6c722ddf351ff346189a8e (patch)
treea214f0e1460ef3aa1a23bd082f87e524b8052c4c /Makefile.PL
Imported Upstream version 0.4
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..693fd4e
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,15 @@
+use ExtUtils::MakeMaker;
+require 5.008;
+my $xt = prompt( "Should I do external tests?\n".
+ "These tests will fail if there is no internet connection or if a firewall\n".
+ "blocks active or passive IPv6 FTP traffic.\n".
+ "[y/N]", 'n' );
+WriteMakefile(
+ NAME => 'Net::INET6Glue',
+ VERSION_FROM => 'lib/Net/INET6Glue.pm',
+ PREREQ_PM => {
+ 'IO::Socket::INET6' => 2.54,
+ 'Net::FTP' => 2.75,
+ },
+ $xt =~m{^y}i ? ( test => { TESTS => 't/*.t t/external/*.t' }):(),
+);