summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2014-01-20 21:34:55 +0100
committergregor herrmann <gregoa@debian.org>2014-01-20 21:34:55 +0100
commitdeb6e6873b6b413723467cb2fc847230306b0301 (patch)
tree66d683a9b3f1a14de3e9330a1e50d91c1f2ee4ef /Makefile.PL
parent97d28e00c342b24f6cf6e2bf182459f40dda3b75 (diff)
Imported Upstream version 0.602
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL15
1 files changed, 12 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 79c099a..5767eda 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -7,13 +7,22 @@ my $xt = prompt(
"[y/N]",
'n'
);
+
+my %INET6 = ( 'IO::Socket::IP' => 0.25 );
+if ( ! eval "require IO::Socket::IP" || $IO::Socket::IP::VERSION < 0.25
+ and eval "require IO::Socket::INET6"
+ and $IO::Socket::INET6::VERSION >= 2.54 ) {
+ %INET6 = ( 'IO::Socket::INET6' => 2.54 );
+ warn "using IO::Socket::INET6 instead of IO::Socket::IP\n";
+}
+
WriteMakefile(
NAME => 'Net::INET6Glue',
- AUTHOR => [ "Steffen Ullrich <sullr@cpan.org>" ],
+ AUTHOR => "Steffen Ullrich <sullr@cpan.org>",
LICENSE => 'perl',
VERSION_FROM => 'lib/Net/INET6Glue.pm',
PREREQ_PM => {
- 'IO::Socket::INET6' => 2.54,
+ %INET6,
'Net::FTP' => 2.75,
},
META_MERGE => {
@@ -21,7 +30,7 @@ WriteMakefile(
license => 'http://dev.perl.org/licenses/',
homepage => 'https://github.com/noxxi/p5-net-inet6glue',
bugtracker => 'https://rt.cpan.org/Dist/Display.html?Queue=Net-INET6Glue',
- Repository => 'https://github.com/noxxi/p5-net-inet6glue',
+ repository => 'https://github.com/noxxi/p5-net-inet6glue',
},
},
$xt =~m{^y}i ? ( test => { TESTS => 't/*.t t/external/*.t' }):(),