summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeikki Vatiainen <hvn@radiatorsoftware.com>2024-01-01 22:43:53 +0200
committerHeikki Vatiainen <hvn@radiatorsoftware.com>2024-01-01 22:43:53 +0200
commite8b2f0864c20be0de7adbb9af87043fb3b257147 (patch)
tree29141002a3a3a953f22f346525de883b07925f16
parent08f9fcd6fdfe24a1af130529fdf040ecc6d22d21 (diff)
GH-454 Tone down warning against mixing compilers and compiler flags.
With Linux and macOS, for example, compiling OpenSSL and Net::SSLeay with gcc and clang appears to work these days. It's even possible to compile Net::SSLeay with a C++ compiler and link it against OpenSSL compiled with a C compiler. On some other platforms it may still be required to use matching compiler and flags, but it seems not to be universally required anymore.
-rw-r--r--Changes5
-rw-r--r--Makefile.PL5
-rw-r--r--README11
3 files changed, 15 insertions, 6 deletions
diff --git a/Changes b/Changes
index 0499175..b4887bd 100644
--- a/Changes
+++ b/Changes
@@ -150,6 +150,11 @@ Revision history for Perl extension Net::SSLeay.
path detection may pick the wrong version. Static
compilation needs seems not to work with the these
versions. Thanks to bulk88 for the initial updates.
+ - Tone down Makefile.PL and README warning against mixing
+ compilers and flags when compiling OpenSSL, Perl and
+ Net::SSLeay. This may still be a requirement on some
+ platforms, but, for example, with Linux and macOS mixing
+ clang and gcc appears to work.
1.93_02 2023-02-22
- Update ppport.h to version 3.68. This eliminates thousands of
diff --git a/Makefile.PL b/Makefile.PL
index 4cd41bc..3112fdd 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -256,8 +256,9 @@ sub ssleay_get_build_opts {
}
print <<EOM;
-*** Be sure to use the same compiler and options to compile your OpenSSL, perl,
- and Net::SSLeay. Mixing and matching compilers is not supported.
+*** If there are build errors, test failures or run-time malfunctions,
+ try to use the same compiler and options to compile your OpenSSL,
+ Perl, and Net::SSLeay.
EOM
if ($^O eq 'MSWin32') {
diff --git a/README b/README
index b38a410..618d6fa 100644
--- a/README
+++ b/README
@@ -48,10 +48,13 @@ Linux distribution's package manager, e.g.:
A future version of Net-SSLeay will remove this requirement when
building against a libssl without support for TLS compression.
-The same C compiler and options should be used to compile all of Perl,
-OpenSSL/LibreSSL, and Net-SSLeay. Mixing compilers and options often
-leads to build errors or run-time malfunctions that are difficult to
-debug.
+If there are build errors, test failures or run-time malfunctions, try
+to use the same compiler and options to compile your OpenSSL, Perl,
+and Net::SSLeay. Mixing compilers and options may lead to build
+errors, test failures or run-time malfunctions, that are difficult to
+debug. The situation in 2024 is that, for example, compiling Perl with
+gcc and Net::SSLeay with clang works on Linux and macOS. With Windows
+it may be easier to use the same compiler and compiler options.
Installing