summaryrefslogtreecommitdiff
path: root/include/osmocom/abis/ipa.h
diff options
context:
space:
mode:
authorThorsten Alteholz <debian@alteholz.de>2017-11-28 18:55:37 +0100
committerThorsten Alteholz <debian@alteholz.de>2018-04-09 19:46:24 +0200
commitb43c9cd3ac22673617613415fa17878d53d7f168 (patch)
treeec94b50759c9f2b015d1a717e2004dec62cea47f /include/osmocom/abis/ipa.h
parent13338adce55fd369fbff0f78fa4af2545899032b (diff)
parent2ad447fb95a63d80584b2792a4f4fbb6ddbfd55d (diff)
Import Debian changes 0.4.0-1
libosmo-abis (0.4.0-1) experimental; urgency=medium * New upstream release * debian/control: SONAME bump of libosmoabis6 and libosmotrau2 * debian/control: bump standard to 4.1.1 (no changes) * update symbols files * add spelling patch
Diffstat (limited to 'include/osmocom/abis/ipa.h')
-rw-r--r--include/osmocom/abis/ipa.h6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/osmocom/abis/ipa.h b/include/osmocom/abis/ipa.h
index 6e9f9dd..a157889 100644
--- a/include/osmocom/abis/ipa.h
+++ b/include/osmocom/abis/ipa.h
@@ -35,9 +35,14 @@ struct ipa_server_conn {
struct osmo_fd ofd;
struct llist_head tx_queue;
int (*closed_cb)(struct ipa_server_conn *peer);
+ int (*ccm_cb)(struct ipa_server_conn *peer, struct msgb *msg,
+ struct tlv_parsed *tlvp, struct ipaccess_unit *ud);
int (*cb)(struct ipa_server_conn *peer, struct msgb *msg);
void *data;
struct msgb *pending_msg;
+ /* remote address information */
+ const char *addr;
+ uint16_t port;
};
struct ipa_server_conn *
@@ -48,6 +53,7 @@ ipa_server_conn_create(void *ctx, struct ipa_server_link *link, int fd,
void ipa_server_conn_destroy(struct ipa_server_conn *peer);
void ipa_server_conn_send(struct ipa_server_conn *peer, struct msgb *msg);
+int ipa_server_conn_ccm(struct ipa_server_conn *conn, struct msgb *msg);
enum ipa_client_conn_state {
IPA_CLIENT_LINK_STATE_NONE = 0,