summaryrefslogtreecommitdiff
path: root/include/osmocom/abis/unixsocket_proto.h
diff options
context:
space:
mode:
authorThorsten Alteholz <debian@alteholz.de>2017-11-28 18:55:37 +0100
committerThorsten Alteholz <debian@alteholz.de>2018-04-09 19:46:24 +0200
commitb43c9cd3ac22673617613415fa17878d53d7f168 (patch)
treeec94b50759c9f2b015d1a717e2004dec62cea47f /include/osmocom/abis/unixsocket_proto.h
parent13338adce55fd369fbff0f78fa4af2545899032b (diff)
parent2ad447fb95a63d80584b2792a4f4fbb6ddbfd55d (diff)
Import Debian changes 0.4.0-1
libosmo-abis (0.4.0-1) experimental; urgency=medium * New upstream release * debian/control: SONAME bump of libosmoabis6 and libosmotrau2 * debian/control: bump standard to 4.1.1 (no changes) * update symbols files * add spelling patch
Diffstat (limited to 'include/osmocom/abis/unixsocket_proto.h')
-rw-r--r--include/osmocom/abis/unixsocket_proto.h31
1 files changed, 31 insertions, 0 deletions
diff --git a/include/osmocom/abis/unixsocket_proto.h b/include/osmocom/abis/unixsocket_proto.h
new file mode 100644
index 0000000..25718ff
--- /dev/null
+++ b/include/osmocom/abis/unixsocket_proto.h
@@ -0,0 +1,31 @@
+
+#ifndef UNIXSOCKET_PROTO_H
+#define UNIXSOCKET_PROTO_H
+
+/* The unix socket protocol is using a 2 byte header
+ * containg the version and type.
+ *
+ * header: | 1b version | 1b type |
+ *
+ * for data packets it would be
+ *
+ * data: | 0x1 | 0x0 | lapd ..|
+ * control: | 0x1 | 0x1 | control payload |
+ *
+ * Atm there is only one control packet:
+ * - set_altc (superchannel or timeslot)
+ *
+ * set_altc payload:
+ * | 4b magic | 1b new_state|
+ * | 0x23004200 | 0x0 | to timeslot
+ * | 0x23004200 | 0x1 | to superchannel
+ */
+
+#define UNIXSOCKET_PROTO_VERSION 0x1
+
+enum {
+ UNIXSOCKET_PROTO_DATA = 0x0,
+ UNIXSOCKET_PROTO_CONTROL = 0x1,
+};
+
+#endif /* UNIXSOCKET_PROTO_H */