summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorRuss Allbery <eagle@windlord>2006-11-10 15:37:31 -0800
committerRuss Allbery <eagle@windlord>2006-11-10 15:37:31 -0800
commitd95d495c280b458c211f3337a5db8c6bdbb3c5c8 (patch)
treebc02c946de50498e2cc369ee72f4bdf0529c51bf /Makefile.in
parentcb2a38e4686cf6978403059a585d11c186cc61fa (diff)
Now actually compiles and appears to work properly. Added the
program PAM argument to set which program to run and fixed lots of syntax errors and extra and missing variables.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 82e7145..6be389a 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -25,12 +25,13 @@ INSTALL = @INSTALL@
INSTALL_DATA = @INSTALL_DATA@
SOURCES = logging.c options.c public.c tokens.c
-OBJECTS = $(SOURCES:.c=.o)
+OBJECTS = $(SOURCES:.c=.o) @LIBOBJS@
all: pam_afs_session.so
pam_afs_session.so: $(OBJECTS)
$(CC) -o $@ $(LDFLAGS) $(OBJECTS) $(LIBS)
+ chmod 644 $@
install: pam_afs_session.so
$(INSTALL) -d $(pamdir)