summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAristotle Pagaltzis <pagaltzis@gmx.de>2022-08-10 00:44:33 +0200
committerAristotle Pagaltzis <pagaltzis@gmx.de>2022-08-10 00:44:33 +0200
commitf2206b97d32586d7e15ce28d3aaa2d2bba6b1306 (patch)
treef852e7cb82df17f3a91921a9cd504ebcb03fb261
parentfb441b6cf3289763b488c239982e05617194f2da (diff)
move boilerplate.pl under inc/
To my dismay I completely missed the fact that ExtUtils::MakeMaker installs not only .pm but also .pl files from the root directory of a distribution into the perl installation. Putting them into a subdirectory prevents this from happening, and choosing inc/ for this purpose is the logical choice.
-rw-r--r--Makefile.PL2
-rw-r--r--inc/boilerplate.pl (renamed from boilerplate.pl)0
2 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 72a8793..30e0859 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -34,7 +34,7 @@ MANIFEST :
distdir : boilerplate
.PHONY : boilerplate
boilerplate : distmeta
- $(PERL) boilerplate.pl $(DISTVNAME)
+ $(PERL) -Ilib inc/boilerplate.pl $(DISTVNAME)
## BOILERPLATE ###############################################################
require ExtUtils::MakeMaker;
diff --git a/boilerplate.pl b/inc/boilerplate.pl
index 77a0cb1..77a0cb1 100644
--- a/boilerplate.pl
+++ b/inc/boilerplate.pl