summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2020-04-21 22:58:33 +0200
committergregor herrmann <gregoa@debian.org>2020-04-21 22:58:33 +0200
commit3dc62dbcf1eadd59dfeee4b68774059664448396 (patch)
treee47708a6b225d9cf364b48eba89e39fbacd5a0e1 /Makefile.PL
parent6b5d05b07ff0b5e6bd7ac370b32091dea884c1b5 (diff)
New upstream version 1.8.1+dfsg
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 30d51ff..abda576 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -15,7 +15,7 @@ elsif($os =~ /^IRIX\d* 6/) { $config='irix_6.h'; }
elsif($os =~ /^OSF1/) { $config='dec_osf.h'; }
elsif($os =~ /^Linux/) { $config='linux.h'; $picobj='linuxapi.o'; }
elsif($os =~ /^AIX/) { $config='aix_4_1.h'; }
-elsif($os =~ /^BSD\/OS 2/ ||
+elsif($os =~ /^dragonfly/i ||
$os =~ /^Darwin/ ||
$os =~ /^FreeBSD/ ||
$os =~ /^NetBSD/ ||
@@ -62,8 +62,8 @@ if ( $os =~ /^SunOS/ ) {
}
# check whether we are using the NetBSD quota library
-if ( (($os =~ /^NetBSD 5\.99\.(\d+)/i) && ($1 >= 59))
- || (($os =~ /^NetBSD (\d+)/i) && ($1 >= 6)) ) {
+if ( (($os =~ /^NetBSD 5\.99\.(\d+)/) && ($1 >= 59))
+ || (($os =~ /^NetBSD (\d+)/) && ($1 >= 6)) ) {
$extralibs .= " -lquota";
}