summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorvenaas <venaas>2009-03-11 10:42:35 +0000
committervenaas <venaas@e88ac4ed-0b26-0410-9574-a7f39faa03bf>2009-03-11 10:42:35 +0000
commitb6cf2205d5b103e27109d2d4a99c234049958b2f (patch)
treedd333d32c985db73497c399aa4d104ee09ac877c
parent1dfd48e25865933734dbd4c6e4eb498a166fc3cc (diff)
Makefile.am for Solaris
git-svn-id: https://svn.testnett.uninett.no/radsecproxy/trunk@487 e88ac4ed-0b26-0410-9574-a7f39faa03bf
-rw-r--r--Makefile.am-solaris37
1 files changed, 37 insertions, 0 deletions
diff --git a/Makefile.am-solaris b/Makefile.am-solaris
new file mode 100644
index 0000000..20f67ae
--- /dev/null
+++ b/Makefile.am-solaris
@@ -0,0 +1,37 @@
+sbin_PROGRAMS = radsecproxy
+
+radsecproxy_SOURCES = radsecproxy.c \
+ tlscommon.c \
+ gconfig.c \
+ util.c \
+ debug.c \
+ list.c \
+ hash.c \
+ tlv11.c \
+ hostport.c \
+ radmsg.c \
+ udp.c \
+ tcp.c \
+ tls.c \
+ dtls.c \
+ radsecproxy.h \
+ tlscommon.h \
+ gconfig.h \
+ debug.h \
+ util.h \
+ list.h \
+ hash.h \
+ tlv11.h \
+ hostport.h \
+ radmsg.h \
+ udp.h \
+ tcp.h \
+ tls.h \
+ dtls.h
+
+radsecproxy_CFLAGS = -g -mt @SSL_CFLAGS@ @TARGET_CFLAGS@
+radsecproxy_LDFLAGS = -lpthread -lsocket -lnsl @SSL_LDFLAGS@ @TARGET_LDFLAGS@
+radsecproxy_LDADD = @SSL_LIBS@
+
+dist_sysconf_DATA = $(srcdir)/radsecproxy.conf-example
+dist_man_MANS = radsecproxy.1 radsecproxy.conf.5