summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordu.net>2012-01-24 14:51:22 +0100
committerLinus Nordberg <linus@nordu.net>2012-01-24 14:52:30 +0100
commitedf4c0475272134cbc2862babba723da5d6be101 (patch)
tree8b22ef4d57ca6115ee6e9a12f7dc0e42a172df58
parent4874dc3d84e23b1f465a1ff8b686aca5ba0a5853 (diff)
Bump library interface revision.
Should really have been done as part of bumping the library version (0.0.2.dev in configure.ac).
-rw-r--r--lib/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index a26750d..294f04e 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,6 +1,22 @@
AUTOMAKE_OPTIONS = foreign
ACLOCAL_AMFLAGS = -I m4
+# Shared library interface version, i.e. -version-info to Libtool,
+# expressed as three integers CURRENT:REVISION:AGE.
+
+# CURRENT is the version number of the current interface. Increment
+# CURRENT when the library interface changes.
+
+# REVISION is the version number of the _implementation_ of the
+# CURRENT interface. Set REVISION to 0 when CURRENT changes,
+# else increment.
+
+# AGE is the number of interfaces this library implements, i.e. how
+# many versions before CURRENT that are supported. Increment AGE
+# when the library interface is _extended_. Set AGE to 0 when the
+# library interface is _changed_.
+
+
SUBDIRS = . examples include
INCLUDES = -I$(srcdir)/include