summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorvenaas <venaas>2008-12-22 10:18:35 +0000
committervenaas <venaas@e88ac4ed-0b26-0410-9574-a7f39faa03bf>2008-12-22 10:18:35 +0000
commit6068df237753e20c504c954504858585d5105a46 (patch)
tree62d4678c8d3cbfdd711f5b66e4eeda0627f36113 /Makefile.am
parentbe2e70adfd0793b34e86e2a7463514923d1882cd (diff)
split out code that is needed only when tls or dtls is used
git-svn-id: https://svn.testnett.uninett.no/radsecproxy/trunk@445 e88ac4ed-0b26-0410-9574-a7f39faa03bf
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e7d1cc..5361f24 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,7 +25,7 @@ radsecproxy_SOURCES = radsecproxy.c \
tls.h \
dtls.h
-radsecproxy_CFLAGS = -g -Wall -pedantic -pthread @SSL_CFLAGS@ @TARGET_CFLAGS@
+radsecproxy_CFLAGS = -g -Wall -pedantic -pthread -DRADPROT_UDP -DRADPROT_TCP -DRADPROT_TLS -DRADPROT_DTLS @SSL_CFLAGS@ @TARGET_CFLAGS@
radsecproxy_LDFLAGS = @SSL_LDFLAGS@ @TARGET_LDFLAGS@
radsecproxy_LDADD = @SSL_LIBS@