summaryrefslogtreecommitdiff
path: root/hostport.h
diff options
context:
space:
mode:
authorSam Hartman <hartmans@painless-security.com>2013-09-30 08:16:09 -0400
committerSam Hartman <hartmans@painless-security.com>2013-09-30 08:16:09 -0400
commit5c48c1f34ebc0662ac24d2a92fdf89c6447a5cf8 (patch)
tree335f62a057f92f5c6f7064daf37025c2a1552373 /hostport.h
parentec43e1ae18f8b3b129ffdae83e20101edd413ff3 (diff)
parent968744389f35996a1e7133dfdaa0ff9f70b50119 (diff)
Merge branch 'moonshot' into debian
Conflicts: lib/Makefile.am lib/build-aux/config.guess lib/build-aux/config.sub lib/build-aux/depcomp lib/build-aux/ltmain.sh lib/build-aux/missing lib/m4/libtool.m4 lib/m4/ltoptions.m4 lib/m4/ltversion.m4 lib/m4/lt~obsolete.m4 lib/radsec.c lib/radsecproxy/tlscommon.c lib/tls.c
Diffstat (limited to 'hostport.h')
-rw-r--r--hostport.h23
1 files changed, 0 insertions, 23 deletions
diff --git a/hostport.h b/hostport.h
deleted file mode 100644
index 01237e2..0000000
--- a/hostport.h
+++ /dev/null
@@ -1,23 +0,0 @@
-/*
- * Copyright (C) 2006-2009 Stig Venaas <venaas@uninett.no>
- *
- * Permission to use, copy, modify, and distribute this software for any
- * purpose with or without fee is hereby granted, provided that the above
- * copyright notice and this permission notice appear in all copies.
- */
-
-#include "hostport_types.h"
-
-struct hostportres *newhostport(char *hostport, char *default_port, uint8_t prefixok);
-int addhostport(struct list **hostports, char **hostport, char *portdefault, uint8_t prefixok);
-void freehostport(struct hostportres *hp);
-void freehostports(struct list *hostports);
-int resolvehostport(struct hostportres *hp, int socktype, uint8_t passive);
-int resolvehostports(struct list *hostports, int socktype);
-struct addrinfo *resolvepassiveaddrinfo(char *hostport, char *default_port, int socktype);
-int addressmatches(struct list *hostports, struct sockaddr *addr, uint8_t checkport);
-int connecttcphostlist(struct list *hostports, struct addrinfo *src);
-
-/* Local Variables: */
-/* c-file-style: "stroustrup" */
-/* End: */