summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordu.net>2010-10-05 22:07:21 +0200
committerLinus Nordberg <linus@nordu.net>2010-10-05 22:07:21 +0200
commit5886bda12130ff8e76c4dd73762c183c1ab31871 (patch)
tree0727f88ee5a5c98ff75ef2c9d740a0553220b66e /lib
parentbf4047ef3d533e819240c2a00ff9bd65e0beba2e (diff)
More info to README and HACKING.
Diffstat (limited to 'lib')
-rw-r--r--lib/HACKING56
-rw-r--r--lib/README9
-rw-r--r--lib/configure.ac2
3 files changed, 46 insertions, 21 deletions
diff --git a/lib/HACKING b/lib/HACKING
index 38826d4..8163fdf 100644
--- a/lib/HACKING
+++ b/lib/HACKING
@@ -1,22 +1,44 @@
HACKING file for libradsec (in Emacs -*- org -*- mode).
-* Design of the libraray
-- three usage models
- - using send and receive calls in blocking mode
- - running the libevent loop, getting callbacks
- - running own event loop, using fd's for select and doing the i/o
- using libradsec send/receive
-* Functionality
-** Not implemented
+
+Status as of libradsec-0.0.1 (2010-10-05).
+
+* Build instructions
+cd libradsec/lib
+ln -s /usr/share/libtool/config/ltmain.sh .. # bug
+sh autogen.sh
+./configure # bug -- won't complain when missing libraries
+make
+examples/client examples/client.conf blocking ; echo $?
+
+* Design of the API
+- There are three usage models.
+ - You use the send and receive calls in blocking mode.
+ - You run the libevent loop and get callbacks instead of doing
+ blocking reads.
+ - You run your own event loop, using fd's for select and do the i/o
+ using the libradsec send/receive calls.
+- Fully reentrant (FIXME: any issues with libfreeradius-radius?)
+
+* Dependencies
+- libfreeradius-radius -- no i/o used
+- libconfuse
+- libevent 2.0.x -- not packaged yet!
+
+* Functionality and quality
+** Tested and verified
+** Not well tested
+- reading config file
+- short read
+- short write
- autoconf/automake/libtool
+** Known issues
+- leaking memory
+- udp issues with libevent
+** Not implemented
- client: matching responses, resending packets
- custom allocation scheme used in all places
- callbacks invoked properly
-- server fail over
-- TLS
-- TLS PSK
-- DTLS
-** Not tested
-- reading config file
-- short read
-- short write
-** Tested and verified
+- server failover
+- TLS support
+- TLS preshared key support
+- DTLS support
diff --git a/lib/README b/lib/README
index e6b9956..2e51aeb 100644
--- a/lib/README
+++ b/lib/README
@@ -1,5 +1,8 @@
-libradsec is a non-working RADIUS library doing UDP, TCP, TLS and
-DTLS.
+libradsec-0.0.1-dev is a non-working RADIUS library doing UDP, TCP,
+TLS and DTLS.
+
+Canonical pickup point:
+http://git.nordu.net/?p=radsecproxy.git;a=shortlog;h=refs/heads/libradsec
libradsec depends on
- libradius from the FreeRADIUS freeradius-server
@@ -13,7 +16,7 @@ To compile the library and the examples, do something like
sh autogen.sh && ./configure && make
If any of the libraries are not found, try setting environment
-variable LDFLAGS at configure time
+variable LDFLAGS at configure time.
LDFLAGS="-L/usr/lib/freeradius -L/usr/local/lib" ./configure
diff --git a/lib/configure.ac b/lib/configure.ac
index 9f1972b..766f7f8 100644
--- a/lib/configure.ac
+++ b/lib/configure.ac
@@ -1,7 +1,7 @@
# -*- Autoconf -*- script for libradsec.
AC_PREREQ([2.65])
-AC_INIT([libradsec], [0.0.1], [linus+libradsec@nordu.net])
+AC_INIT([libradsec], [0.0.1-dev], [linus+libradsec@nordu.net])
AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([radsec.c])