summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2013-01-22 15:45:33 +0100
committerLinus Nordberg <linus@nordberg.se>2013-01-22 15:45:33 +0100
commit84f0770e6ff98f872d0627e759145c5c1ecccebd (patch)
tree7a25321eb37f0ee05b68aad8fe63f5e2911dc54b /lib
parentbbfebbe841a54e3ce68f0744b3c42abf9ce9e293 (diff)
Compile with -Werror.
Diffstat (limited to 'lib')
-rw-r--r--lib/Makefile.am2
-rw-r--r--lib/examples/Makefile.am2
-rw-r--r--lib/radsecproxy/Makefile.am2
-rw-r--r--lib/tests/Makefile.am2
4 files changed, 4 insertions, 4 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 9415c3d..46f573a 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -20,7 +20,7 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = radius radsecproxy . include examples
INCLUDES = -I$(srcdir)/include
-AM_CFLAGS = -Wall -g
+AM_CFLAGS = -Wall -Werror -g
lib_LTLIBRARIES = libradsec.la
diff --git a/lib/examples/Makefile.am b/lib/examples/Makefile.am
index 17b87a3..bfd31e8 100644
--- a/lib/examples/Makefile.am
+++ b/lib/examples/Makefile.am
@@ -1,6 +1,6 @@
AUTOMAKE_OPTIONS = foreign
INCLUDES = -I$(top_srcdir)/include
-AM_CFLAGS = -Wall -g
+AM_CFLAGS = -Wall -Werror -g
noinst_PROGRAMS = client
client_SOURCES = client-blocking.c
diff --git a/lib/radsecproxy/Makefile.am b/lib/radsecproxy/Makefile.am
index 16b66ae..0d4a882 100644
--- a/lib/radsecproxy/Makefile.am
+++ b/lib/radsecproxy/Makefile.am
@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = foreign
ACLOCAL_AMFLAGS = -I m4
INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)
-AM_CFLAGS = -Wall -g
+AM_CFLAGS = -Wall -Werror -g
noinst_LTLIBRARIES = libradsec-radsecproxy.la
diff --git a/lib/tests/Makefile.am b/lib/tests/Makefile.am
index 7c5408b..33ddb51 100644
--- a/lib/tests/Makefile.am
+++ b/lib/tests/Makefile.am
@@ -1,6 +1,6 @@
AUTOMAKE_OPTIONS = foreign
INCLUDES = -I$(top_srcdir)/include
-AM_CFLAGS = -Wall -g
+AM_CFLAGS = -Wall -Werror -g
TESTS = test-udp