summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordu.net>2010-10-19 19:17:42 +0200
committerLinus Nordberg <linus@nordu.net>2010-10-19 19:17:42 +0200
commitc62b9e147af51d77089d04de6763916fb76b1a2d (patch)
tree9f1c6077dfd84522dfbcef8d558a10dfe8d6b090 /lib
parent88adb3a99af7ac04c5f07174acdd54fbf13fee01 (diff)
Move connection related functions to conn.c.
Diffstat (limited to 'lib')
-rw-r--r--lib/Makefile.am1
-rw-r--r--lib/conn.c141
-rw-r--r--lib/radsec.c135
3 files changed, 142 insertions, 135 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 6f01c9a..5d7cd0a 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -9,6 +9,7 @@ lib_LTLIBRARIES = libradsec.la
libradsec_la_SOURCES = \
attr.c \
conf.c \
+ conn.c \
debug.c \
err.c \
packet.c \
diff --git a/lib/conn.c b/lib/conn.c
new file mode 100644
index 0000000..62105e6
--- /dev/null
+++ b/lib/conn.c
@@ -0,0 +1,141 @@
+/* See the file COPYING for licensing information. */
+
+#include <assert.h>
+#include <radsec/radsec.h>
+#include <radsec/radsec-impl.h>
+
+int
+rs_conn_create (struct rs_context *ctx, struct rs_connection **conn,
+ const char *config)
+{
+ struct rs_connection *c;
+
+ c = (struct rs_connection *) malloc (sizeof(struct rs_connection));
+ if (c)
+ {
+ memset (c, 0, sizeof(struct rs_connection));
+ c->ctx = ctx;
+ if (config)
+ {
+ struct rs_realm *r = rs_conf_find_realm (ctx, config);
+ if (r)
+ {
+ struct rs_peer *p;
+
+ c->type = r->type;
+ c->peers = r->peers; /* FIXME: Copy instead? */
+ for (p = c->peers; p; p = p->next)
+ p->conn = c;
+ }
+ }
+ }
+ if (conn)
+ *conn = c;
+ return c ? RSE_OK : rs_err_ctx_push (ctx, RSE_NOMEM, NULL);
+}
+
+void
+rs_conn_set_type (struct rs_connection *conn, rs_conn_type_t type)
+{
+ conn->type = type;
+}
+
+
+struct rs_error *
+_rs_resolv (struct evutil_addrinfo **addr, rs_conn_type_t type,
+ const char *hostname, const char *service)
+{
+ int err;
+ struct evutil_addrinfo hints, *res = NULL;
+
+ memset (&hints, 0, sizeof(struct evutil_addrinfo));
+ hints.ai_family = AF_UNSPEC; /* v4 or v6. */
+ hints.ai_flags = AI_ADDRCONFIG;
+ switch (type)
+ {
+ case RS_CONN_TYPE_NONE:
+ return _rs_err_create (RSE_INVALID_CONN, __FILE__, __LINE__, NULL, NULL);
+ case RS_CONN_TYPE_TCP:
+ /* Fall through. */
+ case RS_CONN_TYPE_TLS:
+ hints.ai_socktype = SOCK_STREAM;
+ hints.ai_protocol = IPPROTO_TCP;
+ break;
+ case RS_CONN_TYPE_UDP:
+ /* Fall through. */
+ case RS_CONN_TYPE_DTLS:
+ hints.ai_socktype = SOCK_DGRAM;
+ hints.ai_protocol = IPPROTO_UDP;
+ break;
+ }
+ err = evutil_getaddrinfo (hostname, service, &hints, &res);
+ if (err)
+ return _rs_err_create (RSE_BADADDR, __FILE__, __LINE__,
+ "%s:%s: bad host name or service name (%s)",
+ hostname, service, evutil_gai_strerror(err));
+ *addr = res; /* Simply use first result. */
+ return NULL;
+}
+
+int
+rs_conn_add_listener (struct rs_connection *conn, rs_conn_type_t type,
+ const char *hostname, int port)
+{
+ return rs_err_conn_push_fl (conn, RSE_NOSYS, __FILE__, __LINE__,
+ "%s: NYI", __func__);
+}
+
+void
+rs_conn_destroy (struct rs_connection *conn)
+{
+ struct rs_peer *p;
+
+#warning "TODO: Disconnect active_peer."
+
+ for (p = conn->peers; p; p = p->next)
+ {
+ if (p->addr)
+ evutil_freeaddrinfo (p->addr);
+ if (p->secret)
+ rs_free (conn->ctx, p->secret);
+ }
+
+ if (conn->evb)
+ event_base_free (conn->evb);
+}
+
+int
+rs_conn_set_eventbase (struct rs_connection *conn, struct event_base *eb)
+{
+ return rs_err_conn_push_fl (conn, RSE_NOSYS, __FILE__, __LINE__,
+ "%s: NYI", __func__);
+}
+
+int
+rs_conn_set_callbacks (struct rs_connection *conn, struct rs_conn_callbacks *cb)
+{
+ return rs_err_conn_push_fl (conn, RSE_NOSYS, __FILE__, __LINE__,
+ "%s: NYI", __func__);
+}
+
+int
+rs_conn_select_server (struct rs_connection *conn, const char *name)
+{
+ return rs_err_conn_push_fl (conn, RSE_NOSYS, __FILE__, __LINE__,
+ "%s: NYI", __func__);
+}
+
+int
+rs_conn_get_current_server (struct rs_connection *conn, const char *name,
+ size_t buflen)
+{
+ return rs_err_conn_push_fl (conn, RSE_NOSYS, __FILE__, __LINE__,
+ "%s: NYI", __func__);
+}
+
+int rs_conn_fd (struct rs_connection *conn)
+{
+ assert (conn);
+ assert (conn->active_peer);
+ return conn->active_peer->fd;
+}
diff --git a/lib/radsec.c b/lib/radsec.c
index 047310b..b7ac9ba 100644
--- a/lib/radsec.c
+++ b/lib/radsec.c
@@ -75,78 +75,6 @@ int rs_context_set_alloc_scheme(struct rs_context *ctx,
"%s: NYI", __func__);
}
-int
-rs_conn_create(struct rs_context *ctx, struct rs_connection **conn,
- const char *config)
-{
- struct rs_connection *c;
-
- c = (struct rs_connection *) malloc (sizeof(struct rs_connection));
- if (c)
- {
- memset (c, 0, sizeof(struct rs_connection));
- c->ctx = ctx;
- if (config)
- {
- struct rs_realm *r = rs_conf_find_realm (ctx, config);
- if (r)
- {
- struct rs_peer *p;
-
- c->type = r->type;
- c->peers = r->peers; /* FIXME: Copy instead? */
- for (p = c->peers; p; p = p->next)
- p->conn = c;
- }
- }
- }
- if (conn)
- *conn = c;
- return c ? RSE_OK : rs_err_ctx_push (ctx, RSE_NOMEM, NULL);
-}
-
-void
-rs_conn_set_type(struct rs_connection *conn, rs_conn_type_t type)
-{
- conn->type = type;
-}
-
-
-struct rs_error *
-_rs_resolv (struct evutil_addrinfo **addr, rs_conn_type_t type,
- const char *hostname, const char *service)
-{
- int err;
- struct evutil_addrinfo hints, *res = NULL;
-
- memset (&hints, 0, sizeof(struct evutil_addrinfo));
- hints.ai_family = AF_UNSPEC; /* v4 or v6. */
- hints.ai_flags = AI_ADDRCONFIG;
- switch (type)
- {
- case RS_CONN_TYPE_NONE:
- return _rs_err_create (RSE_INVALID_CONN, __FILE__, __LINE__, NULL, NULL);
- case RS_CONN_TYPE_TCP:
- /* Fall through. */
- case RS_CONN_TYPE_TLS:
- hints.ai_socktype = SOCK_STREAM;
- hints.ai_protocol = IPPROTO_TCP;
- break;
- case RS_CONN_TYPE_UDP:
- /* Fall through. */
- case RS_CONN_TYPE_DTLS:
- hints.ai_socktype = SOCK_DGRAM;
- hints.ai_protocol = IPPROTO_UDP;
- break;
- }
- err = evutil_getaddrinfo (hostname, service, &hints, &res);
- if (err)
- return _rs_err_create (RSE_BADADDR, __FILE__, __LINE__,
- "%s:%s: bad host name or service name (%s)",
- hostname, service, evutil_gai_strerror(err));
- *addr = res; /* Simply use first result. */
- return NULL;
-}
struct rs_peer *
_rs_peer_create (struct rs_context *ctx, struct rs_peer **rootp)
@@ -220,66 +148,3 @@ rs_server_set_secret (struct rs_peer *server, const char *secret)
return RSE_OK;
}
-int
-rs_conn_add_listener (struct rs_connection *conn, rs_conn_type_t type,
- const char *hostname, int port)
-{
- return rs_err_conn_push_fl (conn, RSE_NOSYS, __FILE__, __LINE__,
- "%s: NYI", __func__);
-}
-
-void
-rs_conn_destroy (struct rs_connection *conn)
-{
- struct rs_peer *p;
-
-#warning "TODO: Disconnect active_peer."
-
- for (p = conn->peers; p; p = p->next)
- {
- if (p->addr)
- evutil_freeaddrinfo (p->addr);
- if (p->secret)
- rs_free (conn->ctx, p->secret);
- }
-
- if (conn->evb)
- event_base_free (conn->evb);
-}
-
-int
-rs_conn_set_eventbase(struct rs_connection *conn, struct event_base *eb)
-{
- return rs_err_conn_push_fl (conn, RSE_NOSYS, __FILE__, __LINE__,
- "%s: NYI", __func__);
-}
-
-int
-rs_conn_set_callbacks(struct rs_connection *conn, struct rs_conn_callbacks *cb)
-{
- return rs_err_conn_push_fl (conn, RSE_NOSYS, __FILE__, __LINE__,
- "%s: NYI", __func__);
-}
-
-int
-rs_conn_select_server(struct rs_connection *conn, const char *name)
-{
- return rs_err_conn_push_fl (conn, RSE_NOSYS, __FILE__, __LINE__,
- "%s: NYI", __func__);
-}
-
-int
-rs_conn_get_current_server(struct rs_connection *conn, const char *name,
- size_t buflen)
-{
- return rs_err_conn_push_fl (conn, RSE_NOSYS, __FILE__, __LINE__,
- "%s: NYI", __func__);
-}
-
-int rs_conn_fd(struct rs_connection *conn)
-{
- assert (conn);
- assert (conn->active_peer);
- return conn->active_peer->fd;
-}
-