summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c8dd005..7585a60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,8 @@ case "${target_os}" in
TARGET_CFLAGS="-DSYS_SOLARIS9 -D_POSIX_PTHREAD_SEMANTICS"
if test "$GCC" != yes ; then
TARGET_CFLAGS="$TARGET_CFLAGS -mt"
+ else
+ TARGET_CFLAGS="$TARGET_CFLAGS -pthread"
fi
TARGET_LDFLAGS="-lpthread -lsocket -lnsl"
;;