summaryrefslogtreecommitdiff
path: root/lib/tests/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lib/tests/Makefile')
-rw-r--r--lib/tests/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/tests/Makefile b/lib/tests/Makefile
new file mode 100644
index 0000000..13316fc
--- /dev/null
+++ b/lib/tests/Makefile
@@ -0,0 +1,10 @@
+CFLAGS = -Wall -g
+
+all: test-blocking
+
+test-blocking: test-blocking.c ../examples/blocking.o ../base.o ../../list.o ../../tlv11.o
+ $(CC) $(CFLAGS) -I .. -I ../examples -o $@ $^
+
+clean:
+ -rm *.o test-blocking
+