summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorOnur Aslan <onuraslan@gmail.com>2010-08-15 05:21:31 +0000
committerOnur Aslan <onuraslan@gmail.com>2010-08-15 05:21:31 +0000
commit6f4db1999c2225c9067411c262ba29e8a7ce38a5 (patch)
tree8261e9304e1e85a0f4fa898ab3a5e2e0e732eb68 /Makefile.PL
[svn-inject] Installing original source of librivescript-perl (1.20)
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100755
index 0000000..e7ffc93
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,11 @@
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+WriteMakefile(
+ NAME => 'RiveScript',
+ VERSION_FROM => 'lib/RiveScript.pm', # finds $VERSION
+ PREREQ_PM => {}, # e.g., Module::Name => 1.1
+ ($] >= 5.005 ? ## Add these new keywords supported since 5.005
+ (ABSTRACT_FROM => 'lib/RiveScript.pm', # retrieve abstract from module
+ AUTHOR => 'Casey Kirsle <casey@cuvou.net>') : ()),
+);