summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortechnion <technion@lolware.net>2014-11-28 14:42:09 +1100
committertechnion <technion@lolware.net>2014-11-28 14:42:09 +1100
commit3d9500c4307963294bc09d76c1b9384249cbe6b1 (patch)
treec98a1b417087280461b15d5f32fbe665357c25f3
parent3f4ed127b9b62f376060125e4b827452ba441f52 (diff)
parenta098d03c3d17a7252cafd6c2d42e988c1e9bbc94 (diff)
Merge pull request #31 from glyph/osx-linking
use install_name_tool to change the library name so that executables linked against it can find it without help from DYLD_LIBRARY_PATH
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 0073e2e..05eeea6 100644
--- a/Makefile
+++ b/Makefile
@@ -42,6 +42,7 @@ install: libscrypt.so.0
install-osx: libscrypt.so.0
$(MAKE_DIR) $(DESTDIR) $(DESTDIR)$(PREFIX) $(DESTDIR)$(LIBDIR) $(DESTDIR)$(INCLUDEDIR)
$(INSTALL_DATA) -pm 0755 libscrypt.so.0 $(DESTDIR)$(LIBDIR)/libscrypt.0.dylib
+ cd $(DESTDIR)$(LIBDIR) && install_name_tool -id $(DESTDIR)$(LIBDIR)/libscrypt.0.dylib $(DESTDIR)$(LIBDIR)/libscrypt.0.dylib
cd $(DESTDIR)$(LIBDIR) && ln -s -f libscrypt.0.dylib $(DESTDIR)$(LIBDIR)/libscrypt.dylib
$(INSTALL_DATA) -pm 0644 libscrypt.h $(DESTDIR)$(INCLUDEDIR)