summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Seligmann <mithrandi@mithrandi.net>2014-12-14 04:23:25 +0200
committerTristan Seligmann <mithrandi@mithrandi.net>2014-12-14 04:23:25 +0200
commit50c2fd628ac252ce982686274e711a2ab570c011 (patch)
tree3d1e67cd02d7545dfaeabba59d152105c4422dc2
parent5dcc64370a17bc551e7bf2b4085468e62b36aa1e (diff)
Work around changes in upstream Makefile.
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 2dfe8b7..ba1ff64 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,8 +4,11 @@
# Uncomment this to turn on verbose mode.
export DH_VERBOSE=1
+export DEB_CFLAGS_MAINT_APPEND=-fPIC
+export DEB_LDFLAGS_MAINT_APPEND=-Wl,-z,now -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version
+
%:
- dh $@
+ dh $@
override_dh_auto_install:
- $(MAKE) DESTDIR=debian/tmp PREFIX=/usr install
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp PREFIX=/usr install install-static