summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Seligmann <mithrandi@mithrandi.net>2014-12-14 05:57:35 +0200
committerTristan Seligmann <mithrandi@mithrandi.net>2014-12-14 05:57:35 +0200
commite8e6fcc1a7d6d2cba74d11157cd0ec7797484cff (patch)
treead7cc2c7978fba40db539c9cc4dd25b566b7fd74
parent5eaeaf5a6d989d89c76c1a135698c69f1ed16f43 (diff)
Fix warning flag.
-rw-r--r--Makefile4
-rw-r--r--debian/patches/fix-makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 05eeea6..4708a9d 100644
--- a/Makefile
+++ b/Makefile
@@ -5,8 +5,8 @@ MAKE_DIR ?= install -d
INSTALL_DATA ?= install
CC?=gcc
-CFLAGS?=-O2 -Wall -g -D_FORTIFY_SOURCE=2 -fstack-protector -fPIC
-LDFLAGS?=-Wl,-z,now -Wl,-z,relro -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version
+CFLAGS += -Wall -fPIC
+LDFLAGS += -Wl,-z,now -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version
CFLAGS_EXTRA?=-Wl,-rpath=.
all: reference
diff --git a/debian/patches/fix-makefile b/debian/patches/fix-makefile
index 3a19cf8..23b7868 100644
--- a/debian/patches/fix-makefile
+++ b/debian/patches/fix-makefile
@@ -14,8 +14,8 @@ Index: libscrypt/Makefile
CC?=gcc
-CFLAGS?=-O2 -Wall -g -D_FORTIFY_SOURCE=2 -fstack-protector -fPIC
-LDFLAGS?=-Wl,-z,now -Wl,-z,relro -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version
-+CFLAGS+=-fPIC
-+LDFLAGS+=-Wl,-z,now -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version
++CFLAGS += -Wall -fPIC
++LDFLAGS += -Wl,-z,now -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version
CFLAGS_EXTRA?=-Wl,-rpath=.
all: reference