summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorTechnion <technion@lolware.net>2013-06-10 00:44:03 -0400
committerTechnion <technion@lolware.net>2013-06-10 00:44:03 -0400
commit6e4c4ba0a586219f4fed8ca0f4e68ce9cae12275 (patch)
tree24cee3b623d09675598b7d43195ea51f3e4a7243 /Makefile
parent9c5dd6256fd52c6ef37e17f442f8b113f24ea013 (diff)
Better soname, CC is variable
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 466d08a..5319ea4 100644
--- a/Makefile
+++ b/Makefile
@@ -6,10 +6,10 @@ OBJS= crypto_scrypt-nosse.o sha256.o crypto_scrypt-hexconvert.o crypto-mcf.o mod
library: $(OBJS)
- gcc -shared -Wl,-soname,libscrypt.so -Wl,--version-script=libscrypt.version -o libscrypt.so -lc $(OBJS)
+ $(CC) -shared -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version -o libscrypt.so -lc $(OBJS)
reference: library main.o
- gcc -Wall -o reference main.o -Wl,-rpath=. -L. -lm -lscrypt
+ $(CC) -Wall -o reference main.o -Wl,-rpath=. -L. -lm -lscrypt
clean:
rm -f *.o reference libscrypt.so